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Forward 
 
Throughout the ages, humans have sought ways to understand and depict our 

environment. As in many areas of human endeavour, new technologies give us 

much more powerful ways of interrogating the natural world, of interpreting what we 

find, and presenting that information. Importantly, in the digital era such technologies 

are becoming ever more affordable and ubiquitous, potentially accessible to many 

more people in many more countries.  

 

However the vast majority of environmental management decisions are not made by 

scientists, but by local people — local government, NGO’s and universities working 

with farmers and householders seeking to feed their families and to earn a livelihood. 

Our challenge is to find ways of combining scientific understanding with fine-grained 

local knowledge and experience to develop better and more sustainable ways of 

managing natural resources and improving human livelihoods.  

 

The use of satellite and digital elevation data for mapping, monitoring and modelling 

has become an important tool assisting effective and timely natural resource 

management. But we need local knowledge to help us to interpret mapped 

landscapes and observed changes so that these data become more useful for 

management and policy. This training manual is a great example of a tool that will 

assist in bringing together local knowledge and experience, with very sophisticated 

remote sensing and landscape modelling technologies. The application of satellite 

data, once an expensive and specialist skill, has become cheap and accessible due 

to falling hardware costs and the availability of high-quality free satellite data and 

software.  

This manual was produced as part of ongoing collaboration between Charles Darwin 
University (Darwin, Australia), Nusa Cendana University (Kupang, West Timor), Halu 
Oleao University (Kendari, South East Sulawesi) with funding support from the 
Australian government (DFAT) through their government partnerships for the 
development program.  This training output provides a platform for long-term   and 
sustained capacity building throughout the region. 
 
Professor Simon Maddocks 
Vice-Chancellor 

Charles Darwin University 
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Geospatial applications for land resource mapping, monitoring and modelling provide 
key data underpinning natural resource management planning (NRM). The current 
generation of free and open source (FOS) geospatial software and free data has 
removed the need for licencing and data purchase, which has been a significant 
barrier to broader involvement in land resource mapping, monitoring and modelling 
for local governments. The increasing availability of free satellite imagery, elevation 
data and raster-based spatial analysis software is providing new opportunities for 
local stakeholders to combine the quantitative analysis of ‘hard’ data with qualitative 
local knowledge. (Fisher et al, 2017) 
 
Whilst open source geospatial software is free, it is in no way inferior to commercial 
GIS applications. On the contrary, free and open source (FOS) software is 
commonly considered to be more secure, reliable, and adaptable to their commercial 
counterparts (Fisher et al, 2017). This is particularly true with geospatial software 
where a suite of robust and highly functional applications are available that often 
outperform commercial options. SAGA GIS, the focus of this manual, is constantly 
updated by developers and the user community, keeping it relevant with cutting edge 
geospatial research. Currently, SAGA offers more than 700 geo-scientific modules 
responding to scientific questions and needs (Conrad et al, 2015). In addition, the 
flexibility and responsiveness allow FOS geospatial software to quickly and 
seamlessly incorporate tailor-made functionality to facilitate specific processes or to 
address particular NRM issues. 
 
Whilst there are a number of sophisticated free open source raster analysis 
packages available, including GRASS, White Box and ILWIS, SAGA GIS was 
chosen as the focus of training as it:  
 
1) provides the easiest one-step process for Landsat data visualisation. 

2) has a simple, one-step, process for sophisticated hydrological and terrain 

modelling 

3) is a compact package that does not require installation and is thus easy to share 

4) has an easy to comprehend interface similar to other GIS packages 

5) works seamlessly with all standard GIS data formats; and 

6) has an active development team responsive to user suggestions for processing 
tools and bug fixes  
 

However, one general criticism of open source software, which is also valid for 
SAGA, is a lack of clear and comprehensive training material. This manual aims to 
help fill this gap and provide a training resource to support the decentralised 
application of sophisticated geospatial analyses using satellite and elevation data to 
improve natural resource governance. 
 
This manual has been developed in tandem with the following English and 
Indonesian language websites that provide further tutorials and links to all the 
datasets used in the examples shown: 

     1. Introduction 
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 sagatutorials.wordpress.com 

 sagagisindonesia.wordpress.com 

 
These sites also include a number of screen-shot videos that show you step-by-step 
how to follow many of the procedures presented. We also encourage people working 
with SAGA to share their work at our user Facebook page: 
www.facebook.com/groups/208599582556485/ 
 
 
 
This training manual has been developed with support from the Australian 
government via funding provided through their Artisanal and Small-scale Mining for 
Development project being implemented by Charles Darwin University. This project 
has been run and the material for this manual developed in collaboration between 
three universities in Eastern Indonesia and Australia 1) Charles Darwin University 
(Darwin), 2) UNDANA University (Kupang) and 3) Haluoleo University (Kendari – 
South East Sulawesi).  
 
Versions of this manual have been published in both Indonesian and 
English, and made available for distribution online through a creative 
commons Attribution-Non-Commercial-Share Alike license.  This 
license lets others remix, tweak, and build upon your work non-commercially, as long 
as they credit you and license their new creations under the identical terms. 
 
 
 
 
 

References 
 
Fisher, R., Hobgen, S. et al. (2017, in press). Free satellite imagery and digital 
elevation model analyses enabling natural resource management in the developing 
world: case studies from Eastern Indonesia  Singapore Journal of Tropical 
Geography. 
 

Conrad, O. et al., (2015). System for Automated Geoscientific Analyses (SAGA) v. 
2.1.4. Geoscientific Model Development, 8, pp.1991–2007. 
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1.1 What will you learn 
 
The aim of this manual is to provide a basic overview of functions within SAGA GIS 
that enable applications in two key areas important for evidence-based natural 
resource management. They are (1) satellite-based mapping and monitoring, and (2) 
terrain analysis and hydrological modelling. The manual is divided up into the 
following sections: 
 

Quick start: This section is designed to enable you to jump into SAGA so 
you can become familiar with its layout and functionality. You will learn here 
how to import satellite imagery, elevation and other forms of GIS data. You 
will also visualise landscapes in 3D and ‘fly’ through satellite imagery. 
 
 
GIS Concepts: This section describes fundamental concepts and 
terminology used when referring to map data. For example, what is GIS, 
what is spatial data, what types of spatial data there are. You will also learn 
about how data is displayed in a GIS, how satellites collect earth images 
and elevation data, and how you can access them free on-line 
 
 
Terrain Analysis: This section will introduce basic concepts in terrain 

analysis and how to prepare elevation data for hydrological analysis. SAGA 
enables the creation of multiple terrain layers which can be used for a 
broad range of ecological modelling, disaster risk, catchment function and 
agricultural applications. You will be surprised how easy it is and how much 
useful landscape information you can produce using SAGA and one data 
layer – Elevation. 

 
 

Working with Landsat/Sentinel 2 Data: The Landsat satellite provides an 
incredibly powerful archive of earth imagery for the whole globe going back 
many decades. Landsat is the primary tool for scientists, governments and 
NGO’s monitoring the earth’s natural resources because it provides regular 
high-quality imagery that’s easy to access, and it’s free! Sentinel 2 is a new 
satellite launched by the European space agency, similar to Landsat, but 
providing higher resolution imagery. Using these data you will learn how to 
quickly and easily import and map land cover and land cover change using 
sophisticated remote sensing techniques. 
 
 
Applications: This section will present a number of example applications 

building on what you have learned in the preceding sections. The section 
will cover these three broad application areas: 
 

1. Fire mapping 

2. Forest cover change 

3. Off-site mine impacts with sediment flow path tracing.  
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Advanced concepts: This section will explore some more advanced ideas 
in satellite image analysis and also present some additional techniques for 
getting the most out of SAGA. This section also explores the use of SAGA 
for Travel time analysis.  Modelling travel time to services has become a 

common public tool for planning infrastructure for improving service 
provision. The aim of the tools described in this section is to provide simple, 
open source, adaptable, interactive travel time modelling tools to allow 
greater access to, and participation in, service access analysis. 

 

 
 

Using the manual 
 
It is suggested that you start at the Quick Start section to get an idea of the layout 
and functionality of SAGA. Whilst working with satellite data in this section it may be 
useful to flip through sections 3 and 4 which provide background on spatial data and 
satellite imagery. 
 
At the start of each section where a practical exercise is used there will be a 
description of the data used, which can be downloaded from the accompanying 
website or DVD. Links will also be provided where there are associated web-based 
video tutorials. This manual only covers a small fraction of the potential uses and 
functions of SAGA and is only meant to be an introduction to promote your own 
exploration. In some cases there will be additional tutorial material on the website not 
included in the manual. 
 
 

 
 
Data access: All the data used in the tutorial examples shown in this manual 
are available for download here:  sagatutorials.wordpress.com/downloads/ 
 

 
 
 

Web support: 

 Additional online training material: sagatutorials.wordpress.com 

 SAGA GIS website and user forums: www.saga-gis.org 

 
 

 
Youtube video channel providing a range of SAGA GIS screen shot 
tutorials related to this manual. 

      
.  
 
 

file:///C:/Users/rfisher/Google%20Drive/SAGA%20Manual_/Layout/Master%20English%20for%20RPF/sagatutorials.wordpress.com/downloads/
file:///C:/Users/rfisher/Google%20Drive/SAGA%20Manual_/English_Version/sagatutorials.wordpress.com


11 
 

 
1.2 What is SAGA? 

SAGA stands for System for Automated Geoscientific Analyses. 
SAGA GIS has been developed by a small group of developers 
primarily based in Germany. Most past and current SAGA 
developments come from the team of J. Böhner and O. Conrad, both 
of whom now work at the Institute of Geography, Section for Physical 
Geography, Klima campus and University of Hamburg, Germany. 
This team has accompanied the SAGA development from its very early beginnings. 

The idea for the development of SAGA evolved in the late 1990s during work on 
several research projects at the Dept. for Physical Geography, Göttingen. A research 
focus was the analysis of raster data, particularly of Digital Elevation Models (DEM), 
which have been used, to predict soil properties, terrain controlled process 
dynamics, as well as climate parametres. This required the development and 
implementation of many new methods for spatial analysis and modelling. 

SAGA has now evolved into a mature robust geospatial analysis package used by 
scientists and natural resource managers around the world. 
 
Which version of SAGA?  
 

One of the main advantages of open-source software is that they are 
regularly updated. This results in bugs being found and fixed quickly and 
new ideas and processing options being incorporated regularly. This 
makes the software generally more robust and up-to-date than commercial 

packages. However, with every new release and update there are changes, some 
minor and some quite significant, making keeping up with the latest version difficult 
at times. In SAGA’s case, there is a new release every three to six months 
depending on how much work the developers have done. This means that training 
material developed five years ago could be up to ten SAGA versions out-of-date. So 
there is always a balance between keeping up with the latest release and using what 
you know. For this training manual, we are using the latest release at the time of 
writing which was SAGA 4.0. Of course, we know that things will change over time 
but the fundamental processes and ideas will stay the same.  
 
SAGA support 
 

Remember that SAGA is created by users to be supported users, so it is 
up to us to proactively support communication between SAGA users and 
developers. We need to work together to develop SAGA and the SAGA 
user community and importantly, where possible, contribute to the 

development of training material. 
The SAGA developers are a very small team of volunteers but they are amazingly 
responsive to user questions and suggestions. We recommend joining the SAGA 
GIS user forum where you can post suggestions and questions 
(https://sourceforge.net/p/saga-gis/discussion/).  
 
Some other sources of SAGA training references include: 

http://www.geowiss.uni-hamburg.de/i-geogr
http://www.uni-hamburg.de/geographie/einrichtungen/phy_geo.html
http://www.uni-hamburg.de/geographie/einrichtungen/phy_geo.html
http://www.klimacampus.de/
http://www.uni-hamburg.de/index_e.html
https://sourceforge.net/p/saga-gis/discussion/).
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 http://marinedataliteracy.org/margis.htm 

 https://rohanfisher.wordpress.com/saga-gis-tutorials/ 

 https://iradafmandaya.wordpress.com/ 

 https://sourceforge.net/p/saga-gis/wiki/Tutorials/ 
 
 

1.3 SAGA Download and Installation.  
 

if you do not have the DVD accompanying this training manual you will first 
need to download SAGA from: 
https://sourceforge.net/projects/saga-gis/files/. 

 

It is recommended you download the latest version in a zipped 
format appropriate for your computer (ie 32 bit or 64 bit). It is 
then simple a matter of on unzipping this file and finding the 
SAGA GIS executable file. You can double-click on this file to 
run it straight from this file. It can also be good to right click on this file and ‘send to 
desktop’, so you have a short-cut there you can easily access anytime. 
 
 
  

http://marinedataliteracy.org/margis.htm
https://rohanfisher.wordpress.com/saga-gis-tutorials/
https://iradafmandaya.wordpress.com/
https://sourceforge.net/p/saga-gis/wiki/Tutorials/
https://sourceforge.net/projects/saga-gis/files/
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2.1 SAGA Layout 
 
When you open SAGA you will see a layout consisting of the following windows: 

 Workspace: is the window where you can, by click through the tabs at the 
bottom of the window, view processing modules, the data you have loaded, 

and the display maps you have created from your data. 

 Work area: is where image maps and other associated data (Attribute Tables, 

Histograms, Plots) are displayed. 

 Object Properties: this window displays and allows you to alter information 

about your loaded data and map displays. 

 Message Window: provides information about processes being run by SAGA 

 

 
Each of the windows can be opened and closed in with the top menu bar icons: 
 

 

       2. Quick Start 
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Workspace Tabs 
 
Tools Tab 
 

 
 
Tools are the SAGA processing functions. SAGA comes with a comprehensive and 
growing set of free tools (over 700 in version 2.3). Not all modules are highly 
sophisticated analysis or modelling tools; many modules perform simple data 
operations, whilst other modules are state-of-the-art in their field of analysis. They 
include: 
 

 Data Import & Export 

 Cartographic Projections & Georeferencing 

 Numerous Raster & Vector Data Tools 

 Image Processing 

 Terrain Analysis 

 Geostatistics 

 

Tools can also be easily accessed through the top ‘Geoprocessing’ drop down menu 
where they are grouped into logical processing groups and are thus generally easier 
to access. 
 
Data Tab 

 
 
The data tab displays any raster (Grid), vector or tables data you have loaded. All 
raster data is displayed as grid layers within a grid system. A grid system groups 
grid layers that have the same grid cell size, have the same number of rows and 

columns and cover the same geographic area. Generally, spatial analysis operations 
are performed on grids with the same grid system 
 

 
A wide variety of raster data can be imported into SAGA, however when raster data 
is saved from SAGA it is saved in a SAGA format (.sgrd). It is possible to change the 
name of loaded grid systems or grid layers in the object properties window. 
 
When vector data is opened into SAGA it will create a 
new layer defined as either point, line or polygon data. 
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To display loaded data either right-click on a data layer and select ‘show’, or simply 
double click on that layer; this data is now opened into a window. To view the data 
layers displayed in a map window click the Map Tab.  
 
Map Tab 

 
Multiple data layers from different grid systems can be displayed in a single map 
layer:  
Map layers can be ‘turned off’ by right clicking a 
map layer and deselecting ‘show layer’ or by 
simply selecting the layer and pressing ‘enter’. 
The order in which map layers are displayed 
can also be changed by right clicking and selecting ‘move up’ or ‘move down’. 
 

 
 
 
 

 

 

 

 

 

Object Properties Tabs 
 
Settings Tab 

 
 
There are a variety of data layer dependent factors that can be viewed and edited as 
‘parametres’ in the ‘Settings’ area. The ‘Settings’ tab area provides users with the 
opportunity to make adjustments to how a data layer appears in the data and map 
view windows. 
 
Description Tab 

 
This tab shows information (size, geographic projection) about the selected layer. 
This data cannot be edited. 
 
Legend Tab 

 
Displays the legend or shows what colours are being used to display which data 
values from the selected layer. 
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History Tab 

 
 

This window displays the processing history for the selected layer. 
 
Attributes Tab 

 
This tab is used with the ‘Action’ (  )tool for displaying the attribute information for a 
selected grid cell on a grid data layer or the attributes associated with a selected 
vector feature on a shapes data layer. 
 
 
 
Work Area Tools 
 
These tools facilitate interaction with a displayed map as described in the following 
table. 
 

 Cursor/Action tool – for selecting points or areas 

 Zoom – zoom in or out of a map display 

 Pan Tool – move around a displayed map 

 Measuring tool  

 Zoom to layer tools 
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2.2 Import and view digital elevation data 
 
One advantage of SAGA software is the ease in working with digital elevation model 
(DEM) data. In this section, we will explore some basic elevation data visualisation 
techniques using DEM data for West Timor (Indonesia). This DEM has been 
produced from data derived from the Shuttle Radar Topographic Mission (See 
section 4.4). The DEM provided has been clipped to west Timor (Indonesia). 
 
This section uses elevation data from west Timor:  West_Timor_(SRTM_80m)  
 
Access tutorial videos here: sagatutorials.wordpress.com/import-and-view-digital-
elevation-data/ 

 
Loading DEM Data 

 
We will start by loading the DEM 
data. 
 
The easiest way to bring data into 
SAGA GIS is to simply drag and 
drop data files from explorer. 
 

Start by dragging the Timor 
elevation data into SAGA. 
 
 
 
 
 
 
In the data Tab window you will see the 
imported data. It is displayed under a 
Grids heading which describes the cell 
size (80m), the number of pixels 
(2385x1947) at the bottom left 
coordinate value (549889, 8853605). 
Below this the imported Grid name is 
then shown.  

 

 

 

 

 

 

 

 

 

 

 

 

https://sagatutorials.wordpress.com/import-and-view-digital-elevation-data/
https://sagatutorials.wordpress.com/import-and-view-digital-elevation-data/
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To display the elevation data double-click the grid (2) and it will appear in the (3) 
display window. 

 

 
 
If you scroll over this grid you will see the 
easting (x), northing (y) and elevation (z) 
values displayed in the bottom right-hand corner. 
 
We can view the digital value of each cell by selecting: 
 

1. Object Properties  
Settings Tab 

2. check mark in the 
‘Show Cell Values’ 

3. Change Decimals 
value of 2 to 0 
(optional) 

4.  Click ‘Apply’. 
 

After that, in the view 
(zoom) several times until 
you see the grids (pixels) 
and a digital value of each 
pixel that. In the example of 
West Timor DEM, the value 
indicates elevation in 
metres. 
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To see more details about loaded data, click on the 
Description tab in the Object Properties window. 

 
Displayed are:  

1. The coordinate system 
2. The coordinate extents 
3. The Cell size 
4. The maximum and minimum data values in 

the grid. 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

2.3 3D Visualisation 
 
SAGA has a number of tools for creating 3D landscape visualisation using DEM data 
sets. 
 
 
The terrain map view tool creates a hill 
shading layer and drapes it over the 
DEM data coloured with an elevation 
colour scheme. 
 
Use:  Geoprocessing > Visualization 
> Grid  >Terrain Map View 

 
1) Select the DEM grid system 

and the DEM grid.  

2) Make the contour lines 250m 

3) Click OK. 
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You will see three 
new data layers 
appear in the data tab 
and the terrain view 
appears in the display 
window and the map 
tab. 
 
 
Explore how the map 
layers are they 
arranged in the map 
tab. Look in the 
settings tab to 
determine which layer 
has a transparency 
setting? 
 
 
 
We can view any elevation data in 3D as long as it is not in a latitude/longitude 
projection (see section 7.1). 3D landscape visualisation can be very useful to assist 

understanding the terrain context of any spatial data you are exploring at.  
 
For 3D display have the data you want to visualise in 3D displayed in your map 
window then click the 3D button on the top menu bar. Set your elevation data, the 
display resolution, and exaggeration. Setting a display resolution of 1000 will 
produce a good quality view without using too much computing resources. The 
exaggeration setting increases the vertical axis, giving this a value of 4 should 
produce a good view. 
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You can change the DEM display 
exaggeration with the keyboard keys 
F1 and F2, or on the top menu bar 
as shown to the right. 
 
 
 

Save the 3-D image. 
 
Use:  3D View> Save as Image 
 
Then specify where these files are stored 
and specify the desired image format (in 
this example the image is stored in the 
Portable Network Graphics format * 
.PNG). 
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2.4 Import and View Landsat data.  
 
The import function in SAGA-GIS makes working with Landsat data a simple one-
step process. There is no other tool, free or commercial, providing an easier way to 
import and visualise Landsat data. 
 
The SAGA tool combines three separate functions into one easy dialogue box. 

 Reprojecting:  Landsat data is by default in a UTM North coordinate system, 

which is problematic for southern hemisphere scenes and people who need 

their data in a geographic (Lat/Long) projection. The Landsat import tool 

allows you to select the scene’s UTM hemisphere or geographic coordinate 

system 

 RGB composite display: The import tool allows you to choose a red, green, 

blue band combination to display directly on import.  

 Contrast enhancing: On import the band combination of choice will 

automatically appear in the map display window with a histogram stretch 

applied to produce a scene that is immediately useable. In addition to this, 

SAGA provides a way to enhance the image display on-the-fly based on the 

currently displayed map window, allowing the rapid stretching of image data 

to show the most detail in your area of interest. 

The SAGA-based Landsat import and display method has some advantages over 
some web-based image viewing services, including: 
 

 Data integration. The use of a desktop GIS platform allows the simple 

incorporation of other spatial data a user may have. For example, .GPX and 

.shp files can be simply dragged and dropped into the SAGA display. 

 Band combinations: The freedom to choose band combinations is important 

for users to find the best way to view the landscape feature of interest. For 

example for fire monitoring and mapping burnt areas the use of a thermal 

band in a display is very helpful. Thus choosing a 4,5,10 band combination 

for import produces an instant burnt area visualisation. 

 Internet access limitation: For many people internet connections are slow 

and unstable. Being able to download once then access, share and explore 

full resolution imagery is important. 

 Multiple image dates: Many Landsat users are interested in using the 

extensive archive to explore land cover change. With the SAGA import 

option, it is a very simple task to import and display multiple image dates into 

a single map layer. 

 Building analysis skills: Having full resolution multiband Landsat imagery in 

a desktop image processing package facilitates the ongoing learning about 

remote sensing and GIS analysis. From understanding basic concepts to 

building capacity in more sophisticated image analysis such as classification, 

elevation data integration, and modelling. 
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2.5 Displaying Landsat data in SAGA. 
 
This section uses Landsat data from west Timor:  West_Timor_Landsat (200mb) 

 

 
To automatically import and display Landsat imagery we need to use the Landsat 
import with options tool.  
 
Use: Geoprocessing>Imagery>Landsat>Landsat Import with Options. 
 
Tip: Once you have accessed a geoprocessing tool once it will then appear at the 
bottom of the geoprocessing dropdown menu for quick access. 
 

1. Navigate to the location of the Landsat GeoTiff files. Select the bands you 
want to display 
2. Choose the output coordinate system you would like the imagery displayed in. 
3. If you have chosen more than 2 image bands you can choose to display it as 
an RGB composite image. In the example below, we have chosen bands 4 (Red), 
5 (Near Infrared 1), 6 (Near Infrared 2) 

 

 
 

 
 
The image automatically opens as a red, green, blue display in a UTM coordinate 
system 
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Now try and zoom to an area of 
interest using the zoom tool. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Adjusting display contrast 
 
 
You can improve the 
display using a technique 
similar to a  ‘contrast 
enhancement’, by clicking 
on the displayed band and 
selecting: Adjust 
Histogram Stretch to 
Map Extent. in the map 
tab right 
 
This essentially adjusts 
the contrast to the colour 
range in the displayed 
window. 
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Landsat 3D visualisation 
 
If you have the digital elevation data 
loaded for the same region and in 
the same coordinate system as 
your displayed Landsat image you 
can use this to view the Landsat in 
3D. 
 
Use exactly the same steps as you 
used previously to display the DEM 
in 3D but this time make sure you 
have your Landsat image display window selected. 
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2.5 Import and viewing Sentinel Data 
 
This section uses Sentinel-2 data from west Timor:  West_Timor_Sentinel-2 (220mb) 

 

 
Access tutorial videos here: sagatutorials.wordpress.com/viewing-sentinel-2-
imagery/ 
 
 
To view sentinel data you can simply drag and drop 
the files straight into SAGA. (Refer to section 3.9 
for downloading Sentinel data.) 
 
 
 
 
 
 
 
 
 
 
 
To view the data as a colour image you need to 
display the Red band (band 4) as an RGB 
composite image by: 
 

1. Selecting band 4 

2. In the settings tab changing the display type to an RGB composite image 

3. Then setting the Blue to the band 2 (B02) and Green to Band 3 (B03). 

https://sagatutorials.wordpress.com/viewing-sentinel-2-imagery/
https://sagatutorials.wordpress.com/viewing-sentinel-2-imagery/
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Exercise 
 
Try displaying the Sentinel imagery together for the same area with Landsat imagery 
and viewing the difference in pixel size or spatial resolution. The example below 
illustrates this difference with the Sentinel 2 imagery (left) and Landsat 8 imagery 
(right) for Kupang airport in west Timor. 
 

 

 
 
Sentinel 2 Imagery (10m)                                    Landsat 8 Imagery (30m)  
 
The concept of spatial resolution in discussed further in Section 4.1 of this manual. 
 

2.6 Adding vector data 
 
This section uses a polygon shape file of the boundary for the main city in West Timor 
(Kupang):  West_Timor_Vector 

 
 
Adding vector data in SAGA can be done by simply 
dragging and dropping the .shp (shapefile) vector file 
into SAGA. For example, to add the vector polygon for 
the boundaries of Kupang city, find the  
Kota_Kupang.shp file and drag it into SAGA. 
 
Alternatively from the top menu: 
 
Use: Geoprocessing>File>Shapes >Load  

 
It should be noted that SAGA will divide raster 
and vector under different data type titles. Raster 
data appears at the SAGA workspace as Grids, 
and vector data appear as Shapes in either line 
(line), area (polygon), or points (point) format.  
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To open the shapefiles in a new map double click on 
one and select new. 
 
We could also display the vector layers over the top of 
one of our existing maps ie, the West Timor DEM, 
Sentinel-2 or Landsat imagery. 
 
 
 
 
To display the vector layer over an 
image select the polygon file in the Data 
Tab then change the display attributes 
in the Settings Tab; change the fill style 
to Transparent, the outline colour to 
black and the line size to 5.  
 
 
 
 
 
 
This will make it easy to see the 
boundary over, for example, the 
Sentinel image as shown here: 
 
Both the Sentinel data and the 
city boundary vector file are in 
the same coordinate projection 
so they display accurately 
together. 
 
Coordinate projections are 
discussed further in section 3.4 
of this manual.  
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The field of mapping and GIS has its own language. This next section explains some 
key concepts and words you might come across when working with map data, 
especially in a fire management context. 

3.1 Data Types 
 
Map data identifies features and positions on the Earth. Within the field of 
mapping/GIS there are two data types used to represent these features; vector and 
raster data. The main difference between these two data types is that vector data is 

presented as a point, line or area, whereas raster data is represented as a grid of 
pixels as shown below. 
 

 
 
 

3.2 Vector Data 
 
Vector data maps features on the ground as points 
(distinct locations), lines and areas (also known as 
polygons). Polygons are line boundaries around the 
perimetre of a feature.  
 
The example to the right is a photo of a feature in 
the real world, and how it might be displayed as 
‘vector’ map data, or lines and polygons. 
 
 
 

 

    3. Introduction to spatial data concepts 
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Common types of vector data include: 
 

 GPX (GPS Exchange format) is a file type associated with 

GPS’, used for collecting data in the field. This format allows 

GPS data (waypoints, routes and tracks) to be opened by 

different GPS devices and software, allowing for easy sharing of 

data without the need for file format conversion. We will go over 

GPS and field data collection later in the course. 

 

 KML (Keyhole Markup Language) is the file type used to display 

geographic/locational data in web-based mapping applications 

such as Google Earth.  

 

 SHP (shapefile) is one of the most common vector file types and 

can be opened in many GIS programs.  

 

3.3 Raster Data 

 
Raster data represents the earth’s surface as 
a grid of cells (also called pixels). Each pixel is 
the same size, and each one represents a 
location. Each pixel has a number value that 
represents some characteristic of that region. 
The satellite imagery from which fires are 
mapped is one example of raster data. With 
satellite imagery, each pixel has a number 
value representing the amount of reflected 
sunlight captured by the satellite sensor. 
 
 
 
The image to the right 
shows a region of the 
Arnhem Land 
escarpment. When we 
zoom in we can see the 
actual pixels making up 
that image. This is very 
similar to the way a 
digital camera or a phone 
stores photos.  
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It is common to display vector and raster data together. For example, you may have 
a GPS point you gathered in the field (Vector) and displayed over satellite imagery 
(Raster) on Google Earth. Each data type can support our planning work in different 
ways. 
 

3.4 Coordinate systems 
 
A coordinate system is a system of recording a location on the earth’s surface – 
every location can be identified by a unique set of numbers. The two most commonly 
used coordinate systems you will come across are the Geographic Coordinate 
System that uses latitude and longitude to mark points on the earth, and the 
Universal Transverse Mercator (UTM) system that uses Eastings and Northings. 
 
The Geographic Coordinate System draws parallel straight lines running east-west 
from the top to the bottom of the earth called lines of latitude (LAT). These lines are 
measured in the number degrees they are from the equator. Lines around the earth 
(radiating out from the north and south poles) are called lines of longitude (LON). 
These lines are measured in the number of degrees they are from an imaginary line 
called the prime meridian. The image below shows this system. 

 
 

 
Image reproduced from Wikipedia http://en.wikipedia.org/wiki/File:Latitude_and_Longitude_of_the_Earth.svg) 

 

 
The UTM system divides the world 
into grid zones, and position is 
indicated by an easting and 
northing position within one of 
these grid cells 
 
Each of these systems has 
advantages and disadvantages.  
 
The UTM coordinate system relies 
on the metre unit of measure, which incorporates the simplicity of the decimal 
system and its easy-to-comprehend units.  
 
On the other hand, the LAT/LON coordinate system relies on the degree, minute, 
and second unit of measure, incorporating the angular system and its cumbersome 
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units of 60. However, the UTM system is cumbersome when working across grid 
zones. In northern Australia, which covers a large area and crosses many grid 
zones, we generally work in a geographic (latitude and longitude) system. However, 
when working across small landscapes, it can be useful to work in a UTM system. 
The most important thing is to understand how your system works. 
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Pictures (raster images) of the earth’s surface captured from satellites orbiting the 
earth are a vital tool for natural resource management.         
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
http://www.nasa.gov/sites/default/files/thumbnails/image/australia.a2015194.0435.250m.jpg 
 
The image above, from the MODIS satellite, shows smoke coming from many fires in 
the Top End of Australia in July 2015. 
 
 
These Earth Resource satellites are 
specifically designed to measure aspects of 
the earth’s surface using onboard ‘sensors’ 
(cameras). These satellites orbit/circle the 
Earth in a known and consistent way so they 
pass over the same spot on the earth’s 
surface at regular intervals. 
 
 
 
There are many Earth resource satellites, each with different sensor and orbit 
characteristics. It is important when using information derived from these satellites to 
understand the type of information each provides and how it can be used.  
 

     4. Introduction to satellite imagery 
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4.1 Key terms in satellite data. 
 
Key to understanding satellite data are their spatial and temporal characteristics. 

 Spatial (space) in the context of satellite data refers to the size of the image. 

This is described in terms of resolution and extent. 

 Spatial resolution refers to the on-ground size of a pixel in a satellite 

image. 

 Spatial extent refers to the on-ground width of a satellite image 

overpass. 
 

 Temporal (time) refers to how long a satellite has been capturing imagery 

(extent) and how frequently it captures imagery (resolution). The temporal 
frequency is also referred to as the revisit frequency. 
 

Spatial Resolution 
 
The graphic to the right shows the on-ground resolution or pixel size of two earth 
resource satellites: (1) Sentinel 2, with each pixel measuring 10 x 10 metres, and (2) 
Landsat, with a 28 x 28 metre resolution. 
 
The on-ground 
resolution has 
significant 
implications for a 
satellite’s ability to 
accurately map on-
ground fire activity.  
 
 
 

 

Spatial Extent 
 
Every Landsat orbit (overpass) captures imagery along an 185km-wide path. This 
means that to capture satellite pictures for all of north Australia, many orbits and 
hundreds of images would be required. 
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Temporal Resolution (Revisit frequency) 

 
The other key factor is revisit frequency or the 
amount of time between when a satellite 
captures an image of the same spot on the 
earth’s surface.  
 
 
 
 
 
 

Spectral Resolution 
 
This describes the number of wavelengths of light sensed by the satellite sensor.  
The graphic below shows the wavelengths and Landsat and Sentinel 2 satellites and 
Band numbers used to store data captured for each wavelength. 
 
The figure below shows the difference between Landsat 7 and Landsat 8 bands – ie 
for Landsat 7 Blue, Green and Red are bands 1,2,3 respectively whilst in Landsat 8 
they are bands 2,3,4. The infrared bands are 4,5,7 for Landsat 7, and 5,6,7 for 
Landsat 8. For all the satellites band 8 is a high-resolution band covering a broad 
spectrum of light. 
 
Once downloaded each spectral band appears as a separate file and can be 
displayed individually or as a (red, green, blue) image composite. Each band has a 
different range of applications. 
 
 
 

 



36 
 

4.2 What is Landsat? 
 
The Landsat series of satellites is the longest running program capturing earth 
resource imagery. Beginning in 1972 the Landsat satellites have collected millions of 
images for the entire globe, making it the most comprehensive collection of earth 
resource data available. The most recent in the series is Landsat 8 launched in 
February 2013. Landsat 8 produces high-quality earth imagery for everywhere on the 
planet every 16 days and is provided as a free service through the United Sate 
Geological Survey (USGS). 
 
 

 
 
 
Landsat 8 imagery has a pixel 
resolution of 28.5 metres and one 
additional band with a 15m resolution. 
Each satellite overpass images 185 km 
of the earth. These image paths are 
subdivided into scenes to allow for 
easier management and distribution 
 
Each image scene is given a path and row number as shown for South East 
Sulawesi in the figure below. 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Landsat 
8 

Resolution Extent 

Spatial 28.5m/15m 175km 

Temporal 16 days 2 years 

Spectral  11 bands 
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The primary difference between Landsat 7 and Landsat 8 imagery is the number of 
spectral bands collected. All recent Landsat imagery contains a combination of 
visible wavelength bands, ie red, green, blue, some infra-red wavelengths and some 
thermal bands. 
 
 

4.3 What is Sentinel 2? 
 
Sentinel 2 is a sensor on two earth resource satellites (Sentinel 2a and Sentinel 2b).  
2a was launched in June 2015 and 2b in March 2017. Both of the satellites are part 
of a fleet set up by the European space agency Copernicus Earth Monitoring 
program, which is the world's largest environmental monitoring project. As described 
above, Sentinel 2 imagery has a higher spatial resolution (10-20m) and, with two 
sensors in the sky, a much higher temporal resolution (5 days). Sentinel 2 replicates 
most (but not all) Landsat image bands (wavelengths) making it easy to compare 
Landsat and Sentinel 2 imagery. 
 

 

 

4.4 What is digital elevation data? 
 
Digital elevation data are 3D models of the 
earth’s surface, usually stored as a pixel grid 
(Raster) format where each cell has the 
average elevation value of its coverage area.  
There are two forms of digital elevation 
models (DEM): 
 

1. Digital surface models where each 

pixel value is the average height of all 

surface features including buildings 
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and vegetation canopy. Digital surface models are commonly produced from 

satellite or photo image pairs. 

 

2. Digital terrain models where the value of each pixel represents the elevation 

of the ground surface. These data are commonly produced by RADAR 

imaging systems. 

 
The primary source of free global elevation data is from the Shuttle Radar 
Topographic Mission (SRTM). These data were produced in 2003 from a dual radar 
system mounted on the space shuttle, at a 90-metre resolution for the whole globe. 
More recently these data have been further processed using other reference data to 
produce a 30-metre product. 
  
This illustration shows the Space 
Shuttle Endeavour orbiting some 
233 kilometres above Earth. With 
C-band and X-band outboard 
antennae at work, one located in 
the Shuttle bay and the other 
located on the end of a 60-metre 
deployable mast, the SRTM radar 
was able to penetrate clouds as 
well as provide its own illumination, 
independent of daylight, obtaining 
3-dimentional topographic images 
of the world's surface up to the 
Arctic and Antarctic Circles. The 
mission completed 222 hours of 
around the clock radar mapping.  
(https://mix.msfc.nasa.gov/abstracts
.php?p=2850) 
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This section covers multiple ways of accessing satellite data free via the internet. 
The following web portals are described: 

 Recent Landsat 8 and Sentinel imagery via Remote Pixel 
(https://remotepixel.ca) 

 Historic Landsat imagery via USGS GloVis Next  (http://glovis.usgs.gov/next/) 

 SRTM elevation data via SRTM tile tool (http://dwtkns.com/srtm/). 

 

5.1 Downloading Landsat and Sentinel 2 imagery 
 
Remote Pixel is a third party web service that provides a number of excellent 
interface tools for downloading satellite imagery. When opening Remote Pixel 
(https://remotepixel.ca) go to the “PROJECTS” page at the top right as shown below: 

 
 
This will take you to a page of tiles linking to a range of 
image download projects. For accessing Landsat 8 and 
Sentinel data click on the SATELLITE SEARCH 
(Landsat/Sentinel) tile. 
 
https://remotepixel.ca/projects/satellitesearch.html 
 
 
 
 
 
 
This will open a map view where you can select 
either Landsat 8 or Sentinel data view. 
 
 
With the Landsat 8 view you will see the individual 
scenes and their path-row numbers 

    5. Accessing free spatial data 

http://glovis.usgs.gov/next/
http://dwtkns.com/srtm/
https://remotepixel.ca/
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With Sentinel data you will see sentinel 
‘tiles’; These are subsets of whole 
Sentinel scenes. 
 
 
  
 
 
 
 
 
 
 
 
When you click on a scene it shows, (to the right), the most recent image.  
 

 
 
 
 
Clicking on this 
image then opens a 
window showing all 
the available 
Landsat scenes. 
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If you click on the download icon on one of the available scenes from this window a 
band list will appear.  
 
Clicking on a band then starts the download.  
 
 
 
 
 
 
 
 
 
 
When you download a Landsat image each band will be labelled with the following 
description code: 

 
 
This is followed by an underscore and the band number (ie, _B8). Each band is in a 
GeoTiff format and a UTM North projection. To bring Landsat data into SAGA in a 
southern hemisphere UTM projection use the Landsat Import tool as described in 
section 2.4.    
 
Similarly, for Sentinel data clicking on a tile shows the latest available images. 
Clicking on the latest image then opens up a new window with all available imagery. 
For Sentinel 2 data this is only goes back to the start of 2016. 

 
 

. 
 
 
 
 
 
 
 
 
 

 
Sentinel data are in a jp2 format (JPEG 2000) and are by default in a UTM 
projection. Sentinel 2 data can be dragged straight into SAGA, no import is required. 
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5.2 Historic Landsat Data downloads – 1972-Present 
 
To download older Landsat data currently the easiest 
way is US government through their Glovis Next portal. 
(http://glovis.usgs.gov/next/) 
 
To use Glovis Next you will first need a USGS 
account. To go to the Login page by clicking the login 
button on the top right of the Glovis Page: 
 
 
There you will need to enter your login details or if 
you have not already registered create a new 
account. 
 
 
 
Using the Glovis interface you will need to: 

1. Choose the data sets you wish to access. 
For older historic data choose Landsat 4-5 
TM. Refer to section 4.2.    

2. The Date range of imagery you are after. 
3. Centre your map on the scene of interest. 

 

 
 

http://glovis.usgs.gov/next/
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After clicking apply the 
most recent image in your 
chosen date range will 
appear in an information 
box in the bottom right that 
will display the name and 
date of the image. Using 
the previous and next 

buttons allows you to 
move onto the next image 
date available. The Select 
button allows you choose 
an image for further 
information or download  
 
By clicking Select, the 

download icon produces a 
pop-up window showing 
the image to download. 
Select the Level-1 GeoTiff data Product to get all image bands for that scene. 
 
 

 
 
This will automatically start the download of the scene in a zipped (Tar,gz) format. 
Once downloaded, right click on the file to unzip it. You will need to unzip twice, first 
to the Tar format, then to the scene band folder. 
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5.3 Downloading elevation (SRTM) data 
 
The easiest way to access and download SRTM data is via the STRM file grabber 
website (http://dwtkns.com/srtm/). From the interactive globe simply choose the tile 

that covers your area of interest and download the Geo-tiff. 
 

 
 
Higher resolution (30 Metre) SRTM data also can 
be downloaded from the USGS Earth Explorer 
website or from the Remote Pixel SRTM 1ARC  
 
Tile Mosaic project: 
https://remotepixel.ca/projects/srtm1arc-
gl.htm. 
 
This project allows you to select a number of 30m resolution SRTM tiles that will then 
be automatically mosaicked together and emailed to you. 
 
 
Note: Before SRTM elevation data can be used for terrain and hydrological 
modelling in SAGA it first needs to be projected into an equal area (metres) 
coordinate system. This process is described in detail in section 7.1. 
  

http://dwtkns.com/srtm/
https://remotepixel.ca/projects/srtm1arc-gl.htm
https://remotepixel.ca/projects/srtm1arc-gl.htm
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5.4 Other Global Spatial Datasets 
 

Global climate data  

WorldClim (http://www.worldclim.org/) is a set of global 

climate layers (climate grids) with a spatial resolution of 
about 1 square kilometre. The data can be used for 
mapping and spatial analysis.  

 

Infrastructure  
 
OpenStreetMap (https://www.openstreetmap.org) is an initiative 
to create and provide free geographic data, such as street maps, 
to anyone. The OpenStreetMap Foundation is an international 
not-for-profit organisation supporting, but not controlling, the 
OpenStreetMap Project. It is dedicated to encouraging the 
growth, development and distribution of free geospatial data and 
to providing geospatial data for anyone to use and share. 
  

http://www.worldclim.org/
http://www.openstreetmap.org/
https://www.openstreetmap.org/
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This section covers the following techniques for visualising satellite data: 

 Working with multiple satellite image band combinations. 

 Creating higher resolution Landsat image visualisations 

 Creating vegetation indices. 

 Displaying multi-date imagery to view land cover change 
 

 
This section we uses Landsat data for West Timor:  West Timor - Landsat Data (204mb) 
 

6.1  Changing band combination display 
 
Satellite imagery is captured in multiple wavelengths of reflected light otherwise 
known as image 'Bands’ (see section 4.1). We can combine three image bands into 

one picture by displaying each band as either Red, Green, or Blue to produce what 
is commonly known as an RGB composite display. In this example, we will load all 
the image bands for the west Timor scene and create some RGB composite 
displays. 
 
Using the Landsat import tool, import all the 
bands but deselect "Show a Composite". In 
this exercise, we will make the composite 
image manually. 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
The loaded data will appear as two new grid 
systems. One for the 30-metre bands and one 
for the 15-metre resolution band 8.  
 
 
 
 
 
 
 

   6. Visualising satellite data 

https://drive.google.com/open?id=0B5W4P15UVvRuc3BLejh6VEhGWkk
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Now display each band 
separately in a new map 
layer, as shown below.  
 
 
 
 
 
 
 

 
 
Have a look at the difference in the way each image band appears. What you can 
see is the difference between the wavelengths of reflected light stored in each band. 
 
We will now combine these 
to produce a 'natural colour' 
RGB composite image. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
To do this select and display the band you want 
to be our red colour. For a ‘natural colour’ use 
Band 4 as ‘Red’. In the settings tab change the 
colour type to RGB composite and set ‘Blue’ to 
Band 2 and ‘Green’ to Band 3 then click ‘apply’. 
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This will result in the display to the right, which is 
similar to what you would see from space. 
 
 
 
 
 
 
 
 
 
 
 
Try displaying Band 6 as Red (ie the one to set 
to display as RGB composite), Band 5 to Green 
and Band 4 to Blue. This band (right) 
combination highlights growing vegetation. 
 
 
 
 
 
 
 
 
 
 
This third image on the right displays the RGB 
band combination 7 6 5. 
 

 

 

 

This last combination uses Band 10 as Red, 
Band 5 as Green and Band 4 as Blue. Land that 
has recently been burnt or cleared is often 
warmer than surrounding areas. So in this image 
combination areas that may have been burnt 
appear as a bright red.  

However, it is important to note that field 
investigation is required to properly determine 
what is happening on the ground.
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6.2 Vegetation Indices 
 
A variety of algorithms have been developed by researchers in an attempt to extract 
the most information from the satellite image spectral bands. Many of these are 
vegetation indices used for monitoring and mapping vegetation vigour. SAGA allows 
the automated calculation of a number of these. 
 
Use: Geoprocessing>Imagery>vegetation Indices 

 

 
 

The example shown below is using the Vegetation Index (Slope Based). Simply 
enter the Red and Near Infrared bands (4 and 5 for Landsat 8) and select <create> 
for the index you would like to calculate. 
 

 
You will see all the new band 
combinations/indices in the data tab: 
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Displaying one of the vegetation indices as 
green as an RGB composite display really 
highlights the distribution of actively growing 
(high photosynthetic activity) vegetation as 
shown in the image below. 
 
To find out the meaning of all the different 
vegetation indices and how they might be 
interpreted you can view further information 
if you select the vegetation index module in 
the Tools tab and select the description tab. 
As shown below it provides a description of 
the algorithms used to calculate each 
indices and references to more information. 
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6.3 Producing a higher resolution Landsat display using band 8 

 
There are several tools within SAGA for combining the 15 metre Landsat 8 Band 8 
with the multi-spectral 30-metre bands. Using the west Timor satellite imagery try 
one of the image sharpening options. For example: 
 
Use: Geoprocessing>Image sharpening>Colour Normalised Brovey 
Sharpening 
 
Enter the 30-metre bands you wish to sharpen and the band 8 grid for the high-
resolution band. 
 

 
 

 
 
Now display the new band 6 grid 
(15m) as a band composite 
image in the settings tab. 
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Display the original 30m band (left image) with the 15m band composite (right 
image) to compare the resolution difference. 
 

 
 
Alternatively a simpler way to combine the two resolutions is to display the band 8 
image with a transparency setting over the top of an RGB composite display of the 
30m bands. 
 

 
 
The result is shown in the left image below. More detail in the image is evident 
compared to the original image (right), however, some spectral (colour) clarity is lost. 
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6.4 Multi-temporal image display 
 
It is possible to display multiple images from different dates (year) to view changes in 
land cover over time. We will do this to examine changes in land cover due to 
mining. 
 
For this section, we will use imagery of a small-scale gold mining area in South East 
Sulawesi (Indonesia). This site in the ‘Bombana’ district experienced a gold rush in 
2008. Using Landsat 5 and Landsat 8 imagery we will look at the land cover change 
caused by the mining activity. Later in section 10.2 we will use the same imagery to 

conduct a classification for the same area in South East Sulawesi. 
 
For this section use: Landsat data from Sulawesi from 1996 and 2015. (219mb)  

 
 
Let’s now display a Landsat 5 image from 
2006 (\Landsat\113-63\2006). The Landsat 5 
bands 3,4,5 (Red, NIR, SWIR1) are 

equivalent to the Landsat 8 bands we used 
earlier (4,5,6). Load the 2006 image with the 
Landsat 5 bands as shown here. 
 
You will now see in the maps tab that we have 3 
images displayed: 2 with differing band 
combinations for 2014 and our new 2006 image. 
Each image is displayed in a different map layer.  
 
To view the imagery from 2006 and 2014 
together drag the 2014 (4,5,6) image into the 
2006 map layer as shown here: 
 
Now by selecting the top-most scene and 
pressing enter we can tab between the image 
dates and easily view changes in land cover. 
 
 
For example the 
images to the right 
clearly display the 
difference between 
the 2006 and 2014 
images in the 
Bombana mining 
region. 
 
 
 
It is important to understand and be able to identify the difference between land 
cover change events that are seasonal and temporary, and those that are longer 
term. In the September 2006 scene above, (late dry season), large areas of burnt 
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grassland can be seen as black scorched areas across the westen half of the image 
whilst in the 2014 image back burnt areas are no longer obvious, whilst blue/purple 
areas of mining activity can be clearly seen.  
 

Exercise 
In the 2014 scene (early dry season), mined areas 
appear blue, water filled.  Look around the scene; what 
other long and short term changes can you see? What 
changes are temporary and what are likely to e long-
term? 
 
To identify some land cover change: 
 
Use: Map>Copy Map to clipboard 

 
tool to copy the images into PowerPoint. Annotate and explain what you think has 
caused the land cover change. 
 

6.5 Mosaicking Satellite imagery 
 
Image mosaicking allows you to combine multiple image scenes or tiles. This is very 
useful if your area of interest sits between two images along a Landsat path or 
multiple SRTM Elevation data tiles. 
 
Following is a step-by-step process for mosaicking Landsat scenes. 
 
This first example here shows the mosaicking of two consecutive Landsat scenes 
from the same path (112/063, 112/064) as shown below. 
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Open the mosaicking tool:  
 
Use: Geoprocessing>Grid >Grid  system>Mosaicking 
 

 
 

 
 

Input two grids of the same image bands from the two scenes. In the example shown 
here the two band 2 grids have been loaded. Name the output Grid with its band ID. 
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This will result in a new Grid System with the 
new mosaicked grid. 
 
 
 
 
 
 
 
 
Do this for each band from the two Landsat scenes. 
 
 
 
 
 
 
 
Displaying the final mosaicked image as a RGB 
composite will give you the image shown 
below. 
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This section describes a number of standard raster image processing tools. These 
include: 

 Coordinate transformation; a way of reprojecting raster and vector files 
between coordinate systems. 

 Clipping raster data with polygons 

 Reclassification 

 Data import and export; important for getting data into and out of formats for 
different software.  

 
For the Coordinate transformation, clipping and reclassification processes we will 
use data from the Top-End of northern Australia to produce a grid with slope classes 
for a national park. 
 
 
The data provided for this section is: SRTM data in with an accompanying (Kakadu) 
national park boundary file.  

 

 

 

7.1 Coordinate transform  
 
Drag and drop the SRTM 
data into SAGA. The 
resulting data is in a 
geographic coordinate 
system (Lat/Long). 
 
 
 
 
 
 
 
You can load shape file 
(vector) data into SAGA by 
simply drag and dropping the 
.shp file. 
 
The example here uses a 
polygon shape file for Kakadu 
National Park boundary. This 
file is in a UTM (Universal Transverse Mercator) projection. 
 
 

    7. Processing tools 

https://drive.google.com/open?id=0B5W4P15UVvRubWUzR0NESU9QN3c
https://drive.google.com/open?id=0B5W4P15UVvRubWUzR0NESU9QN3c


58 
 

 
To be able to conduct 3D visualisation and terrain modelling 
elevation data sets need to be in an equal area or metres grid 
projection. This is so the xy-axis values (metres between cells) is 
the same as scale as the z-axis (metres above sea level value of 
each cell).  
 
 
 
Reprojecting the SRTM data to a UTM 
projection will also allow us to 
combine it with the UTM national park 
polygon file. To reproject first set the 
projection of the current data set. 
 
Right click on the SRTM grid layer and 
select spatial reference: 
 
 
 
 
 
 
 
Set the spatial reference to the WGS 84 geographic coordinate system as shown 
below: 

 

 
 
We can now reproject the elevation data into our UTM zone (53).  
 
Use: Geoprocessing > Projection > Coordinate transformation Grid 

 
In the module dialogue window: 

1. Enter the SRTM grid to be projected 
2. Set the resampling to “Nearest Neighbour” 
3. Set the Projected Coordinate system to UTM Zone 53. 
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A new dialogue box will appear where you can set the output cell size. For standard 
SRTM data this should be 90 metres. 
 
 

 
 
 
 
 
 
 
 
 
 
 
You should now be able to display the Kakadu boundary vector data over the top of 
the new reprojected elevation file. 
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To view the grid data under a polygon file set the fill style to ‘Transparent’ in the 
display settings tab. 

 

7.2  Clipping grids with polygons 
 
Now we can clip the elevation raster grid with the Polygon data using the Clip Grid 
with Polygons module: 
 
Use: Geoprocessing>Shape>Grid>Spatial Extent>Clip Grid with Polygons 

 
In the dialogue box choose the reprojected SRTM data and the Kakadu polygon. 
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The resulting clipped grid as shown here:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7.3 Reclassification 
 
We will now use this elevation dataset to create a slope classification file from Flat to 
very steep. First, we need to create our slope grid: 
 
Use: Geoprocessing>Terrain Analysis > Morphometry > Slope, Aspect 
Curvature 
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In the dialogue box set the elevation to your clipped elevation data set and the slope 
units to degrees. 
 
You will get a result as shown below. 
 

 

 

It can be informative to view the resulting 
terrain metric with hill shading in the 
background to give a better idea of the 
values being represented. The easiest 
way to do this is, with the clipped SRTM 
elevation data selected, in the settings 
Tab set the Display Shading setting to 
normal. 
 
 
 
 
 
Display the slope grid over the SRTM grid (with shading set) and set the 
transparency to 55: 
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Now reclassify the slope data into slope zones (Classes) using the Reclassify Grid 
Values tool. 

 
Use: Geoprocessing> Grid>Values> Reclassify Grid Values 

 
In the dialogue box: 

1. Load the slope grid 
2. For the classification method choose “simple Table” 
3. Open the table 

 

The lookup table set the slope 
minimum and maximum and the 
new slope class. 
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With the new ‘Slope reclassified’ grid right-
click and select ‘Create lookup Table’ 
 

 

 

 

 

 

 

Select unique values as the 
‘Classification Type’. 
 

 

You can see and edit the resulting look-up table and colours in the Settings tab. 
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Now right click and select 
‘Histogram’. This will open a 
graph showing the number 
of cells in each class. 
Clicking the table button 
opens a table of the grid 
values. 
 

 

 

 

This table shows the area in square 
metres of each slope class. Right clicking 
on the table in the data table allows you 
to export it to a format readable be excel. 
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7.5 Exporting an image map 
 
It is often useful to be able to export a map you have created in SAGA for further 
work in another GIS package or as an image for a report or presentation.  
 
To export a displayed map for printing or field work: 
 
Use: Geoprocessing>Map>Save as image to 
workspace 
 
Select a cell size equivalent to the imagery you have 
displayed (ie Landsat band 8 
15m all other bands 30m). 
 
 
Go to the data tab and you will notice 
a new grid system and grid layer will 
have been produced containing the 
saved image. 
 
 
Right click on this to save the image 
to a tiff file format. 
 
 
 
 
 
In the options select Save Georeference. This will 
enable you to open the file in other GIS software in the 
correct coordinate projection and overlay other data. 
For example, you may wish to include other spatial 
data layers and make a map in ARC-Map or Open-
Jump 
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7.6 Importing Data 
 
This section describes how to import Raster (Grid), Vector and field data. 

 
Raster Data 
 
Most raster data formats can be dragged and dropped straight into SAGA GIS; 
inbuilt import functionality automatically converts data into a SAGA format. However, 
you may find that dragging and dropping raster data will use a default averaging (B-
Spline) resampling method. This will change (average) the values of the imported 
pixels. To make sure you keep the same values for imported data you will need to 
change the resampling import method to Nearest Neighbour using the import tool 

as shown below. 

 
Use: Geoprocessing>File>Grid>Import>Import Raster 

 

 
 

 
 

Vector Data 
 

Shape Files 
Shape files can be loaded by either dragging and dropping the .shp file into SAGA or 
opening the file through the data tab or through the top menu 
 
Use: Geoprocessing>File>Shapes>Load 

Google Earth KML 
If you have made a point, line or polygon in Google Earth using the drawing tools 
you can import them into SAGA after first saving as a KML file. Then: 
 
Use: Geoprocessing> File> Shapes> Import Shapes 
 
You then need to define the type of KML file you are importing (point, line or 
polygon) as shown below. This will import the vector layer into the SAGA data tab. 
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7.7 Field data  
 
The most common way to collect geospatial data in the field for display and analysis 
in a GIS is using a GPS. It is, however, becoming more common to use smartphone 
apps connected to the phone’s inbuilt GPS functionality to assist data collection. This 
section describes how you can import field data collected using either a GPS or a 
smartphone application (Avenza Maps).  
 

GPS Data import.  
 
Data collected on a GPS is commonly stored in a GPX format. To import GPX field 
data simply drag and drop it into SAGA, which will automatically convert the GPX 
into your collected points and lines.  
 
Another common and effective way to collect data with field information is using a 
pen and paper and manually recording a point location from a GPS and a set of 
standard attributes for that location. This data can then be entered into an excel table 
and imported into SAGA. 
 
For example the excel table below was produced from hardcopy field notes from a 
survey in Indonesia. 
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To get this data into SAGA first save from 
excel as a .csv or .txt (tab delimited format) 
file. 
 
 
Then drag and drop this file into SAGA. It will appear as a new table layer in the data 
tab.  
 
To import this as attributed point data use: 
 
Use: Shapes>Conversion>Convert table to points 
 
Choose the new table layer as the table to be converted and X as your Easting (or 
Latitude) and Y axis as you Northing (or Longitude) values. 
 

 
 
This will then add a new point data layer with associated field attributes. 

 
 
 

Export map image to field data collection app. 
 
In this section, we will look at how to transfer 
image maps produced in SAGA-GIS to the 
smartphone Avenza Map application for 
collecting point field data.  
 
Using Avenza it is possible to navigate in the 
field with reference to an image map you 
have created in SAGA. This can be very useful if you need to collect field data for a 
satellite image land cover classification and/or if there is a feature on a satellite 
image that you need to ‘ground truth’. Avenza also allows you to collect location data 
and attribute each point with field information and link them to site photos. 
 
 
 

http://www.avenza.com/pdf-maps
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The process involves the following seven steps: 
1. Import satellite imagery into SAGA in a geographic (lat/long) format 
2.  Zoom to your field area of interest 
3.  Save image to workspace 
4. Save as SAGA grid 
5. Save as image 
6. Zip the resulting ‘.tiff’, ‘.twf’ and ‘.prj’ files 
7. Import .zip file into Avenza 

 
 
 

1. Import the Landsat imagery using Geographic Coordinates as the coordinate 
system, and nearest neighbour as the interpolation method.  
 
 

2. Zoom to your areas of interest 
 
 

3. Use: Map>Save As image to workspace, Set the 
cell size to 0.003 (~30m for Landsat imagery). This 
will save your area of interest as a new layer in the 
data tab. 

 
 
 

4. Right click on the new image layer in 
the data tab and save as SAGA Grid 
(.sgrd). Make sure you give it a new 
name describing the area of interest. 

 
5. Right click on the new image layer in 

the data tab and Save As Image and 
save it as a GeoTiff. Make sure you 
give it the same name as you gave 
the SAGA Grid and save the 
Georeference. 
 

 
6. Go to the folder 

where you saved 
the SAGA Grid 
and image files 
and select the.tiff, 
.twf, .prj files, right 
click and zip them. 

 
 
 
 



71 
 

7. You can now import this zipped file into PDF-MAPS via – email, dropbox or 
your device’s SD card. 

 
 

 

 

 

 

 

 

Try downloading Avenza maps for your phones and some Landsat imagery for 

where you live and test it in the field. 

Note that to use Sentinel-2 data for with Avenza maps it first needs to be reprojected 

into a geographic (lat.long) coordinate system from its native UTM format.  
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Image classification is the process of grouping image pixels into similar classes. 
These classes are usually based on a land cover marine environment type. 
Classification techniques can however also be used be monitor environmental 
changes such as mapping burnt areas. There are two main forms of classification 
commonly practised (1) pixel-based classification and (2) object-based classification. 
 
Pixel based classification looks at the spectral response or digital numbers for 
each pixel and uses one of a number of mathematical methods assigns them into a 
class. There are two methods by which pixel classes can be assigned; 
unsupervised and supervised classification.  
 
Classes can be assigned automatically based on a grouping algorithm choosing how 
a pixel should be assigned. Generally, the only user inputs into this process are to 
choose the image bands to be used in the assignment process and the number of 
eventual output classes. This method is commonly referred to as unsupervised 
classification. These classes are usually assigned a Land cover class by reference 
to ground data and the satellite image post-classification. In SAGA unsupervised 
classification is referred to as cluster analysis. 
 
In contrast supervised classification requires a user to define ‘training sites’ of 
known land cover type. Pixels are then grouped into classes based on the spectral 
data from the training site pixels. Pixel based classifications are fast and efficient; 
they can, however, result in errors that are hard to adjust or edit. Unsupervised pixel 
classification is used in the ‘monitoring land cover change’ tutorial in this manual. 
 
Object-based classification, rather than 
looking at individual pixels, groups pixels into 
regions (segments) of similar spectral 
properties. These segments are usually in the 
form of polygons attributed with statistical 
information about the mean spectral 
characteristics of the region. These objects 
can then be classified using unsupervised or 
supervised techniques as with pixel-based 
classifications. Object-based classification 
allows more flexible editing of classified areas 
and allows more sophisticated methods 
incorporating of segment shape and context. 
 
This section has three classification examples: 
 

1. An OBIA based rapid classification of a large mine in Lombok. 
2. A pixel based unsupervised classification of land cover in Kupang Bay (West 

Timor). 
3. An OBIA based supervised classification of land cover of the same area. 

  

   8. Satellite Image classification 

https://sagatutorials.wordpress.com/classification/#OBIA
https://sagatutorials.wordpress.com/land-cover-change-mapping/
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8.1 Object-based classification of Sentinel 2 imagery. 

Rapid mapping of a mine area extent  
 
Demonstrated in this exercise is a rapid way of producing an accurate classification 
and area map of a single feature. In this case it is a large mine site on Lombok Island 
in Indonesia. There are five main steps required: 
Step 1: Display Sentinel 2 imagery downloaded from remote pixel (remotepixel.ca) 
Step 2: Clip to your area of interest 
Step 3: Run the image segmentation 
Step 4: Delete non-mine site polygons. 
Step 5: calculate area.  
 

For this section we will be using data:  Sentinel 2 imagery Lombok (73mb). 

 
Access video tutorial for this section here: 
https://sagatutorials.wordpress.com/segmentation-and-sentinel-2-imagery/ 

 

Display and clip 
 
Open the downloaded 
Sentinel image bands 
into SAGA by simply 
dragging and dropping 
them into SAGA. They 
will automatically open 
in a UTM coordinate 
Grid System. We will 
only need bands 2,4,8 
for this classification.  
Once they are open in 
the data tab display 
them as an RGB composite  
 
We now need to crop the image to our area of interest (ie the mine site). 
 
Use: Geoprocessing>Grids>Grid System > Clip Grids interactive 
 

Select the 3 sentinel bands as our input 
grids. 
 
 
 
 
 
 
 

https://sagatutorials.wordpress.com/segmentation-and-sentinel-2-imagery/
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Using the pointer tool draw a box 
around the mine area. 
Click OK to select the default 
properties on the pop-up clip 
window: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
You will see a new grid system with a 
smaller extent has appeared. You can now 
delete the old grid system containing the 
whole image. 
 
 
 
 
 
 
 
 
 
 
You will now need to display the image as an 
RGB composite again. First display band 8 
then change the display settings in the 
settings TAB. 
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Now we can run the Segmentation process: 
 
Use: Imagery>Segmentation>Object Based Image segmentation 
 

1. Select the 3 Sentinel image bands 

2. Make the image band 

3. Choose ‘Unsupervised Classification’ for your post processing 

4. Deselect split clusters.  

 

 

Display the resulting polygon segmentation layer over the image and set the fill style 
to ‘Transparent’ in the settings tab: 
 

 
 
Now using the pointer tool drag a box across 
polygons within the mine area. This will 
automatically select all polygons of the same 
class which should result in all the mine areas 
being selected.  
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Now right click and select Invert selection. 
This will result in all the non-mine area 
polygons being selected. Delete these to 
leave only the mine polygons by either right 
click and ‘clear Selection’ or pressing delete 
on the key board. 
 
 
 
This should result in just the mine area 
polygons remaining as shown to the left. 
 
 
 
 
 
 
 
 
 
 
 

 
Now we will ‘merge’ the remaining 
polygons to produce one mine area 
polygon. Select all remaining polygons, 
right click and select ‘Merge’. 

 
 
 
 
 
 
 
This should result in just one mine area 
polygons remaining as shown here: 
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We can now calculate the area of this polygon: 
 
Use: Geoprocessing>Shapes>Polygons>Polygon Properties 
 

Select segments as our input and output polygon. This will produce a new attribute in 
the polygon table of the area in square metres. To calculate area directly in hectares, 
change the scaling factor to 0.0001. In the example below, we will first create the m2 

area then use a table calculator to create Ha. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Once you have run the property attributes tool open the attribute table by right 
clicking on the attribute layer and selecting: Attributes>>Show 
 

The table will appear showing the area in m2. 
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To add another field in the table displayed as hectares: 
 
Use: Geoprocessing>table>calculus>table calculator 
 

1. Set the formula to f2/10000. 

This divides the second 

attribute field by 10000. 

2. Set the field name to Ha. 

3. Set the input table to your 

input segmentation polygon. 

 

 
 
 
 
The new area in hectares attribute 
will then appear: 
 
 
 



79 
 

8.2 Unsupervised Classification 
 
This exercise shows a simple unsupervised classification technique for grouping 
areas of similar spectral response. For this exercise we will classify a coastal area in 
west Timor containing ocean, mud flats, grassland and forest. 
 
The data for this section can be downloaded already clipped to our area of interest 
here: Kupang Bay Landsat 8 Clipped (2.2mb). 

 
 

There are four main steps: 

1. Load and display the imagery 

2. Conduct our unsupervised classification 

3. Reclassify our unsupervised classes to land cover classes 

4. View the area statistics. 

 

Load the image bands and display 

the image as an RGB 

composite with Band 6 and Red 
Band 5 as Green and Band 4 as 
blue. 
 
 
 
 
 
You should get a display like this:  

 
 

 
 
 
 
 
 
 
 
 
 
 
 
To conduct the supervised classification: 
 
Use:  Imagery>Classification>Unsupervised>K-Means Clustering for grids 
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1. Select bands 3,4,5,7 as your input bands 

2. Choose a classification method 

3. Set the number of clusters (Classes) to 10. 

 
 
If you have ‘update colours from features’ checked the output classes will be 

similar to your first three input image colours.  Make sure band five is the second 
input grid in your list as this will assure that you get vegetation as green on your 
output classes.  
 
The outputs will look something like 
the image to the right: 
 
Try changing the bands and number 
of classes you use for your 
classification. You will notice different 
bands produce different classification 
results. 
 
The next step is to reclassify these 
arbitrary classes into land cover 
classes. To do this you need to have 
good knowledge and field data for 
the area you are trying to classify so 
you can define what output classes 
are appropriate and what feature on 
the image represents these classes.  
 
 For this exercise we want to reclassify the ten classes to the following six land cover 
types: 
 

 

 

1. Ocean 2. Mudflat 

3. Open Land 4. Grass 

5. Open Forest/Scrub 6. Closed Forest 
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To determine which features represent which land cover type you display the RGB 
composite image next to the cluster image. Using the pointer tool, move it over the 
classified image display the cluster value displayed at the bottom of the screen. 
 
In the image below the RGB composite display is on the left and the classified image 
on the right. the cluster value for an area the pointer is over is shown at the bottom. 
 

 
 
By examining the image and comparing it to the clusters you should be able to 
determine the main land cover type of each cluster. Once you have done this open 
the classification (Cluster) image lookup table and edit the description of each class 
to fit what you have found. 
 
We will use this table to make a reclassification look-up table. 
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Save the table to which you have added 
the Land Cover description to the SAGA 
data tab by pressing the Workspace 
button. You will see a new table appear as 
shown here: 
 
 
 
Open the table and 
press the ‘add field’ 
button on the top 
menu bar as 
shown here. We 
want to add a new 
field that will 
contain our land 
cover class value.  
 
 
 
 
 
 
 
Name the field ‘New’ and make it an integer (number) value. 
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Assign the ‘new ‘ field the land cover class value for each cluster value as shown 
below:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Once you have done this delete the Color, Name and Description fields using the 
delete field button. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This should result in a table as shown here that will be used as our reclassification 
table 
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To reclassify the cluster grid: 
 
Use: Geoprocessing>Grid>Values>Change Grid Values 
 

Select the cluster grid to reclassify then: 
 

1. Open the reclassification look up table 

2. Press the load button 

3. Select the table you have just modified from the workspace 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This will load your table; 
click ‘Okay’ to run the 
reclassification. 
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Right click on the 
resulting change grid 
to create a lookup 
table with unique 
values. This will allow 
us to colour and 
name each class. 
 
Change the colour and name of the reclassified grid to match the land cover classes: 
 
 

 
 
 

 
 
 
 
 
It is now also possible to view the area values of 
each class: Right click on the reclassified grid and 
Select Histogram: 
 
 
 
 
 
 
 
 
 
 
 
 
 
The histogram window shows the number 
of cells for each class.  
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Clicking the table button in the top menu bar above the histogram opens a table 
showing the area in m2  class. 
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8.3 Supervised OBIA 
 
This exercise shows a simple Segmentation classification technique for grouping 
areas of similar spectral characteristics. As with the previous unsupervised 
classification classify a coastal area in west Timor containing ocean, mud flats, 
grassland and forest. 
 
For this section Landsat data has been clipped to our area of interest here: Kupang 

Bay Landsat 8 Clipped (2.2mb).  
 

 
Access a supervised OBIA video tutorial: 
sagatutorials.wordpress.com/supervised-segmentation-classification/ 
 
There are six main steps: 

1. Load and display the imagery 

2. Conduct our segmentation 

3. Select ‘training sites’ telling the computer what Land cover type (class) 

various segments (polygons)  are in. 

4. Run the supervised classification 

5. Edit the classification 

6. Create and view area statistics 

 

Load the image bands and display the image as an RGB 

composite with Band 6 and Red Band 5 as Green and 

Band 4 as blue. 
 
 

Run the image segmentation: 
 
Use: Geoprocessing>Imagery>classification>Obia 

 
Then: 

1. select bands 3,4,5,6 

2. Adjust the Band 

Width for seed 

generation to 5 (this 

will slightly increase 

the size of polygons 

produced). 

3. Set post processing 

to none.  

 
 
 

https://drive.google.com/file/d/0B2AvESxtL2YBRnhvM0g2U0ZHUk0/view?usp=sharing
https://drive.google.com/file/d/0B2AvESxtL2YBRnhvM0g2U0ZHUk0/view?usp=sharing
https://sagatutorials.wordpress.com/supervised-segmentation-classification/
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Double click on the resulting segmentation 
polygon file and display it over the image map 
display. In the settings tab  change the fill style 

to opaque 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
View the attribute table for the segmentation.  
Right click on the segmentation file and 
Select: 
Attributes>Show. 

 
 
 
 
 
 
We now want to add a new ‘Training’ 
attribute to the table. We will then be able to 
select polygons and enter into the new 
‘Training’ attribute the land cover type of a polygon. 

 
This process is called training because we are training the classification how to 
identify all regions land cover type based on a number of representative sites 
 
 
To add the new Training attribute: 

1. Click the add attribute button 

2. Enter  ‘training’ as the attribute name 

3. Click OK.  
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Now you can start the process of selecting training sites. Click on a single polygon 
and open the attribute tab. You will see a number of attributes for the selected 
polygon including all the mean band values for the bands used in the segmentation 
and lastly the new attribute ‘Training’. 
 
In the example below a mangrove polygon is selected to Mangrove has been 
entered as the training attribute. This is our first “Training Site’.  
 
 

 
 
Carry on selecting a number of training sites (5-10) for each land cover class. For 
example below a grass polygon has been selected. 
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For this exercise create training sites for seven: 

1. Forest 

2. Mangrove 

3. Open Forest 

4. Grass 

5. Bare ground 

6. Mud Flat 

7. Ocean 

 
Once you believe you have a representative sample of polygons selected for each 
land cover class we can conduct our supervised classification: 
 
Use: Shapes>Table>Supervised Classification for Shapes 

 
1. Select the segment 

polygon file for the 

input 

2. Select a bands 

3,4,5,6 as our input 

features 

3. Select the training 

attribute as our 

input training 

classes 

4. Choose Minimum 

Distance as the 

training algorithm 
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For step 2 you will get a pop-up window 
where you check the bands you wish to 
use. 
 
 
 
 
 
 
 
 
 
 
 
The resulting output polygon classification will 
be coloured randomly: 
 
 
 
 
 
 
 
 
 
 
 
 
 
Open the Lookup table 
and change the 
colours appropriately.  
 
 
 
 
 
 
 
 
 
In the settings deselect the Outline value.  
 
 
 
 
 
 
 



92 
 

The resulting image classification looks 
good but we can see there are some 
clear errors where some mountain 
forests have been classified as 
mangroves. 
 
 
 
 
 
 
 
 
 
 
Part of the power of Segmentation classification is that it is easy to manually edit 
incorrectly classified polygons. We can manually edit these mangrove segments to 
change them to their appropriate land cover class. For example below is an area of 
forest incorrectly classified as mangrove. 
 
 

 
Select one of the incorrectly classified polygons: 
 

 
 

Change the ‘Class_NR’ (Number value) and ‘Class_ID’ name to the correct land 
cover, ie Grass. 
 

 
 
Once you have edited the image we can now look at some area statistics for the 
classification. First we need to conduct a polygon dissolve: 
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Use: Geoprocessing>Shapes>Polygons>Dissolve 
 
 
Choose Class ID as the attribute to dissolve 
all polygons on: 
 
 
 
 
 
 
 
 
We first need to create a look-up table for the 
dissolved polygons so we can get area 
statistics for each land cover class and not 
each polygon. Right click on the new dissolved 
polygon data file in the Data table and select 
create look-up table. Set the classification 
method to unique values; 
 
Now create an area property for our dissolved polygons. 
 
Use: Shapes>Polygons>Polygon Properties. 
 
Select out dissolved classification segments as the input file and Area as the output 

static we want. 
 
Right click on the segmented 
file and select 
Attributes>Show to see the 
new AREA attribute. 
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It is possible to export the table for further analysis in other software. 
 
Use: Geoprocessing> File>Table>Export 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The output text file can then be graphed in excel. 
 

 

 

 
  

    9. Hydrology and terrain modelling 
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SAGA GIS has some very powerful terrain and hydrological modelling tools. In this 
section you will learn methods for (1) 3D visualisation, (2) terrain analysis and (3) 
hydrological analysis. 
 
 
The data for this section can be downloaded here: West Timor – elevation Data 

 

 
Access a video tutorial for this section here: sagatutorials.wordpress.com/basic-terrain-
analysis/ 

 

9.1 Create watershed basins – preprocessing 
 
In order to produce hydrological flow models we 
need to produce an elevation dataset free of ‘Sinks’ 
or depressions that would capture the flow of water. 
The figure to the right is an example of a model with 
a ‘Sink’ and the same surface after ‘Sinks’ are filled 
and overland flow is continuous. 
 
Add the Timor Barat DEM as the input. The output 
includes a filled DEM and watershed basins (DAS). 
To produce a sink filled elevation data: 
 
Use: Terrain Analysis>Preprocessing>Fill Sinks 
(Wang Liu). 
 
 

 
 
Choose the grid system and the DEM grid. 
The ‘Fill sinks’ module produces three new layers: 
 

1. “TimorB_SRTM [no sinks]” , the sink filled grid 
2. “Flow directions” the direction of water flow through each cell 
3. Watershed basins” or catchments. 

 

   9. Hydrology and terrain modelling 

https://sagatutorials.wordpress.com/basic-terrain-analysis/
https://sagatutorials.wordpress.com/basic-terrain-analysis/
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Double click on layer Watershed basins 
to display it in the map as shown to the 
right: 
 
 
 
 
 
 
We will conduct further analysis on just 
one catchment delineated by the fill sink 
tool. To clip our data to one catchment 
we must first convert our raster 
watershed data-set to watershed 
polygons. To do this: 
 
Use: Geoprocessing>Shapes>Grid>Vectorising Grid Classes 
 

Choose the watershed layer as the input. Select ‘each island as a separate polygon’ 
under the ‘vectorised class as’ options. This makes sure that each catchment 
polygon can be selected individually. 
 

 
 
 
Once the process is complete display the new shape file watershed basin layer and 
select one of the larger catchments with your cursor tool. 
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Cut the DEM layer using the selected catchment. 
 
Use: Geoprocessing>Shapes>Grid>Spatial Extent>Clip grid with polygon 
 

1. Choose the Grid system 
2. Select just the  DEM as the input layer 
3. Choose watershed basins as the input grid 

 

 

You will notice a new grid system with smaller extents has been made. This is the 
clipped grid. Double click on the new grid to display it over the Watershed shape file. 
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Although it is a new Grid it has taken the name of the old grid. In order to avoid 
confusion change the name of the new grid in the settings tab. In the example shown 
here we have called it DEM DAS Noelmina. ‘DAS’ is the Indonesian name for a 
catchment and Noelmina is the name of the catchment clipped in the example 
shown. 
 

 
 
 
By right clicking in on the new grid 
layer it is possible to save it. It will be 
default save as a SAGA Grid format 
(.srgd). 

 
Now we have prepared our catchment 
we can conduct some further analysis. 
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9.2 Basic Terrain Analysis 
 
The basic terrain analysis tool is very powerful, automatically producing 16 terrain 
and hydrological metric outputs. 
 
A new window will then ask you to input the grid system and the elevation grid to 
use.  You will see a list of all the terrain parameters that will be created by this 
module. 
 

 

Enter the input elevation Grid, click OK. 
 
New Grids and Shape files will appear in the data Tab. It may take a minute for the 
processing of all the grids to complete. Double click each grid to see the result in a 
map window. 
 
A description of some of the key outputs from this process is shown following. 
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Basic Terrain Parametres 

 

Analytical Hill Shading 
 

Produces a grid shaded as if by sunlight 
This is a very useful tool for visualising topography. 
 

 

Slope 
 

This creates a grid of slope. You can see the slope value in 
degrees displayed at the bottom of the SAGA window. 
 
 

 

Aspect 

This creates a grid of aspect or facing direction. You can see 
the slope value in degrees displayed at the bottom of the 
SAGA window. 

 

Plan/Profile Curvature 
 
These grids describe the form of landscape 
features. These parameters can be useful for 
modelling landslide risk. 

 

 
 
Convergence Index 
 
This module calculates an index of convergence/divergence 
of overland water flow. 

 

Wetness index 
 

Produces a grid showing water accumulation. This can be 
useful for soil or flood mapping. 
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LS Factor 

Is a combination of Slope and Slope length which combined 
are is a key attribute for predicting erosion potential within a 
landscape. 
 

 

Altitude above channel network 
 

This grid can be useful for potential flood prediction. 
 
 
 

 
 
Channels 
 
Produces a vector file of drainage channels. One of the 
attributes of this data is the Strahler order which is a measure 
of the order of the stream in the drainage network. This can be 
useful for understanding potential magnitude of streamflow. 
 
 
 

 
 
Drainage Basins 
Produces a shape file of water catchments (DAS). 
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Displaying the terrain parameters in 3D mode will help 
you understand what they represent. 

 

Try exploring other analysis tools 

For example: 

 Landform Classification: (Terrain Analysis > terrain Classification > TPI Based 
Landform Classification) 
 

 
 

 Solar Radiation: (Terrain Analysis > Lighting > Potential Incoming solar 
radiation) 
 

 
 

 Wind: (Terrain Analysis > Climate and Weather > Wind) 
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9.3 Hydrological flow modelling 
 
There is a variety of way to assess flow over a landscape in SAGA. This example 
allows you to interactively initiate points of flow over corrected (Sink Filled) elevation 
data. 
 
Use: Geoprocessing> Terrain Analysis>Hydrology>Flow Accumulation 
>Downslope Area (Interactive) 

 

  

Select the resulting downslope area grid and in the settings tab set the maximum no 
Data value to 0. This will make the background transparent so you can see flow 
accumulation over the top of other terrain displayed. 
 

  

 

Open the Downslope area grid into a map 
window over your terrain display 
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Use the pointer tool to initiate 
a flow path. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
Try viewing this in 3D:  
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This section contains tutorials for three practical application examples using 
techniques and data described in the previous sections: (1) Mapping fire extents, (2) 
Mapping forest cover change and (3) modelling mining related sediment flows. 
 

Mapping wildfires 
 

Wildfire is common across a variety of landscapes and poses a serious threat to life, 
property, natural resources and biodiversity. The example in this section is from the 
tropical savannas of northern Australia where we use an object-based image 
segmentation technique to quickly mapping an area of savanna grassland fire. 
 

Mapping forest cover change  
 

Landsat imagery provides a unique data set for assessing environmental change 
over time and has become the primary dataset for hundreds of Land Use and Land 
cover change (LULCC) studies. The example in this section investigates the extent 
of forest loss in South East Sulawesi (Indonesia) using recent and historic Landsat 
imagery. 
 

Assessing potential sediment flows from a field survey of small-scale mining  

 
This application imagines that mine site location data has been collected in the field 
using a GPS and the coordinate locations entered into excel. This data is then used 
to look at potential sediment flow paths from these mining points. This tutorial uses 
elevation data from Indonesian west Timor.   
 

Assessing potential toxic heavy metal flows from satellite imagery 
 

By combining land cover and disturbance data derived from Satellite imagery with 
elevation data for hydrology modelling we can investigate catchment scale impacts 
from mining related sediment flow.  

  10. Application examples 
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4.1 Using Object-Based Image Analysis in SAGA to map fire extent 
 

Savannas landscapes occur in monsoonal 
climates with short intense wet seasons and 
a long dry season across the world. This 
wet-dry flux promotes rapid grass growth 
followed by a long period of curing resulting 
in the most fire-prone landscapes in the 
world. Across northern Australia, on 
average 19% of the 1.9 million km2 of 
tropical savannas burn each year. These 
Savanna landscapes have evolved over the 
at least the last 50000+ years through the 
strategic use of fire by aboriginal people 
 
Over the last fifteen years there has been 
increasing effort to support fire 
management using satellite-derived fire 
information to help guide strategic burning programs. This exercise uses Landsat 
imagery from a savanna region of Northern Australia to illustrate the process of 
mapping burnt areas to inform operation planning and analysis. 
 
Burnt areas usually show up clearly using a display combination including Landsat 8 
band 10. Band 10 is the thermal (Heat) detecting band. Because burnt areas are 
often black due to charred biomass they absorb and emit a lot of thermal energy thus 
the good response in Band 10.  SAGA can be used to quickly and easily map burnt 
areas from Landsat imagery using an Object Based Image Analysis processes.  
 
The data for this section: Australia Fire mapping - Landsat 8 Clipped (64mb) 

 
 
Access fire mapping  video tutorials here: 
sagatutorials.wordpress.com/mapping-fires-from-satellite-imagery/ 
 
 
As SAGA works with data loaded into RAM segmentation of very large data sets, 
such as a whole Landsat scene requires a lot of processing power. The method 
shown here allows for rapid burnt area assessment for smaller areas and is most 
appropriate for mapping particular fire events or management regions.   
 
For this exercise, the imagery provided for download 
includes only bands 4,5 and 10. Import these bands 
using the Landsat import with options tool using band 10 
for red. You will notice the imagery has already been cut 
to make a smaller file for download however for this 
exercise you will need to clip this image again to one 
large burnt area for mapping as shown to the right.  
 
 
Use: Geoprocessing>Grids>Grid System > Clip Grids interactive 

https://drive.google.com/open?id=0B2AvESxtL2YBTFBkeE9wTl9QYlk
https://sagatutorials.wordpress.com/mapping-fires-from-satellite-imagery/
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After you have clipped the grid a new grid layer 
system layer will appear. Look at the number of 
pixels values to determine the new, smaller grid. 
The original image will have over 7000 pixels in the 
width and height; the new clipped image will be 
smaller than this. 
 
 
 
 
 
 
Once you have clipped a grid you need to ‘turn off’ 
the Clip Grids interactive tool by deselecting it in the 
tools menu. 
 
 
 
 
 
 
 
To display the clipped grid first display the 
band 10 layer as a map then in the 
settings window set the display type to 
RGB Composite, >Blue to Band 4, and > 
Green to Band 5; press apply. This will 

produce an RGB display image. 
 
 
 
 
 
 
Now you can run the Segmentation process: 

 

Use:   Geoprocessing > Imagery > Segmentation >  OBIA  > Object Based 
Image analysis 
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In the dialogue box: 

1. Select all the image layers from your clipped dataset. 
2. ‘Band width for Seed Point Generation’: increasing the size of this number 

will increase the size and decrease the number of polygons created. In this 
example of have increased this number to 8 from the default value of 3 to 
decrease the number of polygons produced. It is worth trying larger band 
width values to produce datasets with fewer polygons which will be easier to 
work with subsequently.  

3. Select unsupervised classification for the post-processing method. 
4. Choose the number of different classes for the polygons. 
5. Deselect ‘Split Clusters’. This will allow us to quickly select all polygons of 

the same class designation. 
 
After the classification is finished display the 
dissolved polygon layer over the satellite 
imagery and set its fill to transparent 
 
It should look something like this: 
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Use the pointer tool to select a number of 
polygons within the burnt area; this should select 
all burnt area polygons as shown: 
 
 
 
 
 
 
 
 
 
 
Now we need to copy the selection to a new 
shapes layer. 
 
Use: Geoprocessing> Shapes > Selection > 
Copy selection to new shapes layer  

 
 
 
 
 
 
You should now have a shape file layer like the 
image on the right. 
 
 
To clean up the section classification we now 
need to separate the polygons in the new 
shapes layer so we can edit (Delete) individual 
polygons. 
 
 
 
 
 
 
Use: Geoprocessing>Shapes >  Polygons > Polygon Parts to separate 
Polygons  

 
 
Now display the new ‘selection Parts’ shape 
layer over the satellite imagery. 
 
Turn off the old segment layer in the map 
view by double clicking on it. Now using the 
pointer tool you can select and delete 
individual polygons incorrectly mapped. 



110 
 

  
 
Once you have cleaned up the classification select all the remaining polygons, right 
click and “Merge Selection.” This will combine all polygons of the same class: 
 

 
 
You can now calculate the area burnt in the same way as we did for the previous 
Sentinel example in section 8.1. 
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10.2 Forest cover change mapping using Image differencing  
 
Over recent years the destruction of the world’s 
tropical forests has become an urgent international 
issue, particularly with regard to their role as a 
major carbon sink and stores. Satellite-derived data 
on land cover and land use has become the 
accepted baseline source of information for 
assessing the state of tropical forests. 
 

This example uses an image differences technique 
to highlight changes in forest cover between 
satellite image dates. In this case, we are looking at 
forest cover change in South East Sulawesi. 
 
 
This section uses: Landsat data from Sulawesi from 1996 and 2015. You can download 
these data here (219mb). Only three Landsat image bands are provided to reduce the 
download size. 

 
Access land cover change mapping  video tutorials here: 
sagatutorials.wordpress.com/land-cover-change-image-differencing/ 
 
Steps involved: 
 

1. Convert Landsat 8 imagery from 16bit to 8bit data so it is the same as the 

Landsat 5 imagery 

2. Subtract 1996 imagery from the 2015 imagery using Grid Calculator. 

3. Conduct unsupervised classification on the differenced bands. 

4. Reclassify to aggregate forest cover change classes. 

5. Convert forest cover change class to polygons. 

6.  Edit cover change polygon to remove errors and calculate area 

 

Data Preparation Landsat 5 and Landsat 8 

 
Note: This is the same data and visualisation process as used in section 6.4. 
 
Open the Landsat data for the region of Southeast Sulawesi and then open Landsat 
8 (2015). 
 
Use: Geoprocessing> Imagery> Landsat> Import Landsat With Options. 
 
For the Landsat 5 (1996) image import bands 2,5,6. 
For the Landsat 8 (2015) image import bands 3,6,7. 
 
 

https://sagatutorials.wordpress.com/land-cover-change-image-differencing/
https://sagatutorials.wordpress.com/land-cover-change-image-differencing/#reclass


112 
 

Now clip the image to our study area of interest. 
For this example clip to the area as shown by 
the red box in the Landsat images to the right. 
This a region where there has been significant 
forest cover change. Use the  Landsat 8 2015 
for the input grids Use the pointer tool to draw a 
box around the area of interest (Clip Grids). 
 
 
Use: Geoprocessing > Grid > Grid System > 
Clip Grid Interactive 
 
 
 
 
Now clip the 1996 imagery to the same area so 
they are in the same grid system: 
 
Use: Geoprocessing > Grids > Clip Grids. 
 
Input the three bands from Landsat 1996.  
 
For extent choose ‘grid system’ and choose the 
clipped grid system produced with the Clip Grid 
Interactive for the Landsat 8 data. As shown 
below. 
 
 
 

 
 
 
You should end up with one grid system 
containing all the bands for 1996 and 2015: 
Display the two image bands as an RGB 
composite image to visualise the Forest 
Cover change. 
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Convert Landsat 8 to 8-bit imagery 
 
Because we are working between Landsat 5 and Landsat 8 imagery we need to 
convert the image data format. Landsat 8 imagery is stored as 32-bit data whilst all 
other is sorted in 8bit format. To do this conversion: 
 
Use: Geoprocessing > Grid > Calculus > Grid Calculator. 

 
For each 2015 (Landsat 8) grid band use the formula g1/256 
 

 
 
The resulting image will be the same as an 8-bit 
band. Each band (3,5,7) will need to be converted 
individually. 
 
 
Once you have converted all bands we can 
subtract the image bands for the two years from 
each other. 
 
 
 
 
 
 

https://sagatutorials.wordpress.com/land-cover-change-mapping/image013-4/
https://sagatutorials.wordpress.com/land-cover-change-mapping/image011-3/
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Note it is necessary that each image is in the same Grid System to be able to 
conduct the image differencing. The example shown here is based on using imagery 
already clipped to the same area of interest grid system as shown in the previous 
land cover change example. 

 

 Image Difference 

 
For each band subtract (8bit)  2015 imagery from the  1996 imagery. Because the 
different Landsat satellites have a different number of bands the same spectral 
bands have a different band number allocation so for example: 
8bit band 3 = band 2 Landsat 1996 
8bit band 7 = band 7 Landsat 1996 
8bit band 6 = band 5 Landsat 1996 
 
To create the difference image: 
 
Use:  Geoprocessing>Grid > Calculus > Grid Calculator 
 
With this calculation formula (g1 – g2) + 128. as shown below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
Conduct the image difference for each of the 
three bands for both image years 
individually.  Remember to change the output grid 
allocation to “Create” after processing each band 
so as to not over-write the previous process. 
 
When finished you should have a difference grid 
for the three bands as shown here. 
 
 
 
Now display these as a RGB composite as follows: Diff and 7 = red, diff band 6 = 
green and diff band 3 = blue. 
 
Display the difference image over the original imagery to determine the meaning of 
the different difference image colours. In this case, we see an image similar to that 
shown below where the brighter areas are those with reduced forest cover. 
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Cluster Analysis 
 
Now run an unsupervised classification on the difference grid to determine areas of 
change. 
 
Use: Geoprocessing > Imagery > Classification > Unsupervised > K-Means 
Clustering Analysis For Grids 
 

.  
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In this case, try setting the number of clusters 
(Classes) to five. We end up with a classified 
image similar to that shown to the left: 
 
 
 
 
 
 
 
 
 
 
By comparing to the two original 
images (1996, 2015) we can 
determine the classes showing 
forest cover loss.  
 
To assist identifying the classes use 
the pointer tool to select an area on 
the classified image and open the 
attributes tab. 
 
 
 
 
 
 
 
 
 
 
 
You will see a matrix of numbers 
representing the class values within you 
selection area. In the example blow it is 
showing the forest cover difference 
classes as 4 and 5. Note for this to work 
you need to have the correct image 
(classified grid) selected in the data tab. 
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Reclassification 
 
Now reclassify the grids so that bands 4-5, the forest cover change classes, become 
1 and all other classes become 0.  
 
Use: Geoprocessing>Grid>Values>Reclassify 

 
Set ‘simple table’ 
as the method 
and the operator 
as ‘min<=value 
<+max’ 
 
 
Open the lookup 
table (click the 
selector button 
next to Colums3, 
Row3) 
 
 
 
 
 
 
 
You will need to 
edit the lookup 
table to add as 
many rows as 
you have classes 
ie 5. Set the 
minimum and 
maximum 1-5 
and the new 
output values for 
each class. e 
want our “new” 

forest classes to 
be  1. 
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After running the reclassification we are able to look at the histogram values. 
 
Right click on 
reclassification grid 
layer and select 
histogram 
and area tables 
Select the histogram 
and click the table 
button in the top 
window bar. 
 
 
 
 
 
 
 
 
 
 

 

Vectorising grid classes 
We will now convert the resulting classification to a polygon file to assist assessing 
the region of deforestation and to calculate total area. 
 
Use:  Geoprocessing>Shapes > Grid > Vectorization > Vectorising Grid 
Classes. 
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Display the resulting polygon 
classification over the 1996 
imagery and set the polygon fill 
display to transparent. Using the 
pointer tool it is now possible to 
manually edit the polygon 
classification to remove areas 
mistakenly included in the forest 
cover change classification. 
 
 
 
 
 
 
 
 
 

       
 
Right click on the polygon layer and under the attributed menu select show. this will 
open the attribute table.  You will see there is currently an entry for each individual 
polygon. We want to merge these into one polygon that we can calculate the area 
for. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

https://sagatutorials.wordpress.com/land-cover-change-image-differencing/2016-11-27-07_26_18-saga-03-lc81130632015292lgn00_b7/
https://sagatutorials.wordpress.com/land-cover-change-image-differencing/2016-11-27-07_27_04-saga-03-lc81130632015292lgn00_b7/
https://sagatutorials.wordpress.com/land-cover-change-image-differencing/2016-11-27-07_27_22-saga-03-lc81130632015292lgn00_b7/
https://sagatutorials.wordpress.com/land-cover-change-image-differencing/2016-11-27-07_29_25-saga-01-clusters_reclassified/
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To merge all use the 
pointer tool to drag a box 
around the whole image to 
select all polygons. Now 
right click on the image 
and select “Merge 
Selection”. 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
View the attribute table again and you will now see only one polygon: 
 

 
 
 

https://sagatutorials.wordpress.com/land-cover-change-image-differencing/2016-11-27-07_28_35-saga-03-lc81130632015292lgn00_b7/
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Land cover change assessment can also be conducted by classifying 
Imagery into land cover classes for each image date (year) as shown in 
section 8. This technique allows for a more sophisticated assessment of 
change between land cover types. This is described in more detail in 
section 8.2-8.3. 
 

To calculate the area of this polygon: 
 
Use: Geoprocessing>Shapes>Polygons>Polygon Properties. 
 
Select your merged class 
(Cluster) polygon layer 
and tick Area as the 
output property. 
 
 
 
 
 
 
 
 
 
 
 
You will then see area appear as a value in the class polygon layer's attribute table. 
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10.3 Assessing sediment flows from a field survey of small-scale mining 
in west Timor 

 
This tutorial uses data from Indonesian west Timor to 
explore the impacts of small-scale (artisanal) manganese 
mining in one catchment.  
(https://asm4d.wordpress.com/). 
 
Artisanal and small-scale mining (ASM) involves up to 30 
million people worldwide contributing 15-20% of global 
mineral and metal production. This form of mining is 
generally defined as a community activity with little 
capital input or formal recognition, focusing on marginal 
or small deposits. The number of people involved in ASM 
has increased substantially over the last ten years as 
world mineral prices have shot up. Despite its scale this form of mining is often 
viewed negatively by governments and international agencies due to the potential for 
adverse environmental and health impacts. However artisanal and small-scale 
mining does provide poor people direct access to the mineral wealth of their land, 
providing diversified livelihood’s and positively develop community resilience.  
 
 
This section uses elevation data from west Timor:  West_Timor_(SRTM_80m)  
 
 
The example application described here imagines that location data of mining sites 
have been collected in the field using a GPS and the coordinate locations entered 
into excel. This data is then used to look at potential sediment flow paths from these 
mining points. The process described in this section involves the following steps: 
 

1. Import field data CSV file into SAGA 
2. Convert to point data 
3. Add erosions potential (LS Factor) values from grid to points 
4. Convert points to Grid 
5. Use this grid to model flow paths 

 
 
 
 

Import field data CSV file into SAGA 
  
The CSV file used here is included with the west Timor elevation data download. 
 
Load the CSV file by simply dragging and dropping it into SAGA (as shown in 
section 7.7). 

 
Now convert the imported location table to point data: 
 
Use: Shapes>Conversion>Convert table to points 

 

https://asm4d.wordpress.com/
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Choose the resulting table layer as the table to be converted and x as your Easting 
(or Latitude) and Y axis as you Northing (or Longitude) values (as shown in section 
7.7). 
 

Intersecting Raster and point data 
 

 
It is possible to add values from terrain grids to point data. For this example we will 

add Length Slope (LS) factor value to our mine points. As described in section 

9.2 the LS factor is one of the primary measures of erosion potential. We, 

therefore, will use the LS factor value to weight the sediment flow amount from 

each point.  Use the basic terrain analysis tool to create an LS factor grid for one 

catchment in the west Timor elevation data following the method is shown in 

Section 9. Then add the LS factor values to the point data:  

 

Use: Geoprocessing>Shapes>Grid>GridValues>Add Grid Values to Points. 
 

The module window will then ask for: 
 

 The point shape we want to add the data to. 

 The results file (choose [create] to make a new point layer). 
 The grid we want to take the parameters data from (This can be multiple 

grids) 

 And the method for extracting the attribute data. Use “Nearest Neighbour” 
 

 
 

 

 

 

 

 

 

 

 

Check that the new 

terrain attributes 

have been added by 

checking the 

attribute table: Right 

click on the new 

shape file and select 

Attribute>>Show. 
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A LS-Factor tribute column with values should appear for each point. 
 

 

 

 

 

 
Visualising Sediment flow. 
 

We will now use these points to visualise sediment flow in the catchment. To do this 

we first need to make the point data into grid data.   

 
Use: Geoprocessing>Grid>Gridding>Shapes to Grid 
 

Select Random Points as your input grid with LS factor as the output  
 

 
 
You will now have a new grid (random points (LS Factor)). 
 
To create a sediment flow grid from these points: 
 
Use: Geoprocessing>Terrain Analysis>Hydrology>Flow Accumulation>Flow 
Accumulation (Top Down) 
 

Set the elevation data set to the sink filled catchment elevation grid and the weights 
to the LS factor grid. 
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You should see an output grid like this: 
 
 
 
 
 
 
 
 
 
 
 
 
 
Setting the No Data maximum value to 0 in the 
settings tab allows you to visualize the flow data 
over your other data.  
 
 
 
 
 
 
Try then viewing the output in 3D:   
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10.4 Assessing potential toxic heavy metal flows from a satellite-based 
assessment of a small-scale mine area in South East Sulawesi 
 
Artisanal gold mining in the Bombana 
District of Southeast Sulawesi began 
with a gold rush in late 2008.  From 
September 2008 until April 2009, 
official records show that more than 
63,000 people flooded into the district 
from neighbouring areas and beyond 
the province.  Without meaningful 
guidance from the government, the 
gold rush quickly led to a variety of 
unexpected and deleterious social and 
environmental 
impacts.    Environmental damage has 
been widespread with increased erosion and river sedimentation from river bank and 
alluvial mining, the conversion of forest land and markedly reduced downstream river 
flows and water quality. Since these events and the emergence of community 
opposition to the poorly regulated ASM activities, government efforts have focused 
on issuing mining licenses to private companies and restricting ASM activities.  
 
 
 
For this exercise, we will be first classifying mining areas from a from a small scale 
mining region in South East Sulawesi using Object-Based Image analysis 
segmentation techniques. We will then use this classification for conducting a 
hydrological analysis of potential heavy metal flows through the lands scape using 
hydrological modelling tools. The four follow steps will be used in this exercise: 
 

1. Import Landsat Imagery and identify mining areas 
2.  Classify mining areas using an image segmentation approach 
3. Open Digital Elevation Data and Fill sinks 
4.  Run Flow tracing analysis to identify affected catchments and outflow points 

 
 

This section uses: Landsat data from Sulawesi from 1996 and 2015. (219mb)  

 
Access a video tutorial here: 
https://sagatutorials.wordpress.com/mapping-mines-site-sediment-flows/ 
 
 
Import imagery 

 
In this exercise we will map the extent of gold mining in Bombana using imagery 
from October 18 2015. Load bands 3,6,7 from this image date and in the displayed 
map zoom to the Bombana mining area.   
 

https://sagatutorials.wordpress.com/mapping-mines-site-sediment-flows/


127 
 

 
Use: Geoprocessing>Imagery>Landsat Import With options 

 

 
 
 
Zoom to the mining area and in 
the Map Tab right-click on the 
displayed layer and select Adjust 
Histogram to map extent. 
 
 
 
 
 
 
 
 
 
 
 
 
The mining areas should appear clearly as 
blue. This is a reflectance response from 
standing muddy water. 
 
 
 
Clip imagery to our area of interest 
Look carefully at the imagery to identify all 
the mining areas. We will now cut the 
imagery to include just the mining area. 
 
 
 
 
Use: Geoprocessing>Tools>Grid>Grid System>Clip Grid Interactive 
 
 
 
Select the grid system and all the 
loaded grids to clip. 
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Now use the cursor tool to draw a 
rectangle around the mining region. 
 
You will next see a box asking you to 
confirm your selected extent. If your 
selection was wrong you can select cancel 
and select your area again. 
 
 
 
 
 
 
 
 
 
 
 
Once you have made a correct selection your new 
dataset will appear in the data tab: 
You will be able to see which is your new dataset by 
the smaller extent values in the grid system. 
 
 
 
 
 
 
 
 
 
Right click on the larger grid 
system and close it:  
 
 
We will not need to work with the full Landsat data again. 
  
 
 
To redisplay the new clipped imagery 
as an RGB composite double click on 
the band 7 layer to display it then in 
the properties tab for that band; (1) 
Select RGB composite as the display 
type (2) Blue as Band 3 and (3) 
Green as band 6 then click apply. 
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Run Object Based Image Analysis (Segmentation) 

 

Use:   Geoprocessing > Imagery > Segmentation >  OBIA  > Object Based 
Image analysis 

 

1) Select your cropped 

data and the three 

bands. 

 

2) Set band width for 

seed generation to 

2. Changing this 

changes the size of 

segments produced. 

 
3) Select unsupervised 

classification and 50 

classes for post processing 

 
4) Deselect Split clusters. This will mean that we select multiple polygons of the 

same class. 

 

A new shapes “segments” data set will be produced. Double click on this to display it 
over your satellite imagery. 

 

 

 

Make the segment shape file transparent so you can view the underlying data in the 
settings tab. Set the fill style to transparent:  
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Now using the cursor 
tool select a number of 
polygons surrounding 
mined areas. Selecting 
one polygon will then 
select all polygons of 
the same class. Use 
the CTRL key to select 

additional polygons.  

 

Select enough polygon 
classes to capture 
most of the mined area 
without too many 
polygons outside the 
mined area selected 
as shown here 
Now we need to copy 
the selection to a new shapes layer. 
 
 Use: Geoprocessing>Shapes > Selection 
> Copy selection to new shapes layer  
 
 
 
 
 
 
 

 

Edit the mine site selection 
 
To clean up the section classification we now need to separate the polygons in the 
new shapes layer so we can edit (Delete) individual polygons. 
 
Use: Geoprocessing>Shapes >  Polygons > Polygon Parts to separate 
Polygons  
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Now display the new ‘selection Parts’ shape layer over the satellite imagery. 
 
Turn off the old 
segment layer in the 
map view by double 
clicking on it. You 
should see something 
like shown here: 
 
 
 
 
 
 
 
 
 
 
If you now make the polygon selection transparent you can select (Using the cursor 
tool) and delete incorrect polygons.  
 
 
 
 
 
 
 
 
 
 
 
 
Once you have cleaned up the mine classification select all the mine site polygons 
then right click to Merge Selection into one multi-part polygon. 
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Once you have done this 
right click on the Polygon 
layer in the Data Tab to view 
the attribute table for the 
merged mining area 
classification. 
 
There should only be a few 
classes (Clusters). Make 
sure that each cluster has 
the same value 
(1) as we will use 
this as the value 
to weight the 
sediment flow 
analysis. 
 
 
 
 
 

Sediment flow analysis 
 
 

Load the South East Sulawesi DEM grid. We will use 
this grid when we convert our classified segments to a 
raster file.  
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Convert cleaned up classification to raster data 
 
Use: Geoprocessing> Grid>Gridding>Shapes to Grid 
 
1) Select cluster 

as the attribute 
value the grid 
cells will take. 

2) Select the 
loaded DEM 
grid system as 
the target 
output grid 
system for the 
new grid. 

 
 
 
Display the resulting mined area raster grid over the DEM. 
 
 

Preprocess the DEM 

 
Before we can do a flow analysis we need to fill sinks Fill sink. Remember to 
produce a sink filled elevation data; 
 
Use: Geoprocessing>Terrain Analysis>Preprocessing>Fill Sinks (Wang Liu).  
 
 
 
 
 
 
 
 
 
 
Have a look at the resulting catchment 
boundary grid. 
 
Can you use this to predict where the 
sediment form the mine sites will flow? 
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Run flow path tracing. 
 
Use: Geoprocessing > Terrain analysis > Hydrology > Flow accumulation > 
Flow tracing 
 

 
[Note try changing the flow accumulation method you use and see how the 
results differ] 
 
 
Double click on the resulting Flow 
Accumulation grid to display the 

result. To see the flow paths over the 
elevation data you will need to go into 
the Setting Tab and set the No Data 
Maximum value to 0. This will make 

the 0 values transparent. 
 
 
Try displaying the flow paths over a 3D representation of the landscape as shown 
below. 
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Trav 
 
 
 
This section covers the following concepts: 
 
 
 
Tool Chains  

 
SAGA Tool Chains capability allows multiple modules to be joined together to 
automate and speed up complex processing sequences.  
 
 
Travel time analysis: 

 
Described are two SAGA-GIS tool chains that automate and simplify some of the 
processes required for conducting raster based travel time analysis. The tools also 
allow a degree of interactivity and adaptability supporting the rapid exploration of 
multiple travel time scenarios through altering continuous variables, such as travel 
speed as well as adding discrete factors such as barriers, new roads or services. 
 
 
Error Matrix 
 
An error or confusion Matrix is a technique for comparing changes between two 
raster (grid) data sets that is commonly used for land cover change analysis. 
 

 
Atmospheric correction 

 
Imagery reflectance values can be converted to Top Of Atmosphere (TOA) 
Reflectance (combined surface and atmospheric reflectance) to reduce variability 
between scenes from different dates through a normalization for solar irradiance.  
 
 
Troubleshooting 

 
This section should help with some common known issues with SAGA   

  11.  Advanced concepts 
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11.1 Tool Chains 
 
SAGA Tool Chains capability allows multiple modules to be joined together to 
automate and speed up complex processing sequences. Tool chains are similar to 
the ARC-Map model builder however instead of a graphic interface SAGA uses 
an xml file to join processing modules. The easiest way to start creating a tool chain 

is through exporting a files processing history as an xml file then editing it in Notepad 
++ (https://notepad-plus-plus.org/download/). The process is quite easy and, as you 
get the hang of building tool chains you’ll find them incredibly useful. 
 
The SAGA team have created a number of Chain Tools that you can investigate to 
get an idea of how they work.  You will find them in the ‘\modules\toolchains’ folder of 
your SAGA installation.  The following section described two tool chains developed 
to assist cost distance analysis applications for modelling travel time to services. 
 
You can find a short video tutorial showing the creation of a simple tool chain for 
processing elevation data at https://sagatutorials.wordpress.com/tool-chains/.The 
example produces a catchment area polygon file and a high erosion risk grid based 
on a LS Factor analysis. 

  

https://notepad-plus-plus.org/
https://notepad-plus-plus.org/
https://notepad-plus-plus.org/download/
https://sagatutorials.wordpress.com/tool-chains/
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11.2 Travel time analysis tools  
 
Modelling travel time to services has become a common tool for evidence-based 
infrastructure planning to assist improved public service provision. However, most of 
the travel time modelling tools currently available are in expensive, complex, 
proprietary GIS software limiting their decentralised application. Improving the 
accuracy and relevance Travel time analysis requires greater accessibility to, and 
flexibility in, travel time modelling tools to facilitate the incorporation of local 
knowledge and the rapid exploration of multiple travel scenarios. The tools described 
in this section were developed to support simple open source, adaptable, interactive 
travel time modelling tools allowing greater access to and participation in service 
access analysis. 
 
This section describes tools developed for SAGA-GIS software that automates and 
simplifies some of the processes required for conducting raster based travel time 
analysis. The tools described have been developed as SAGA GIS tool chains. As 
described in the previous section tool chains link multiple SAGA processes into one 
tool using simple xml scripting code. The two tools produced are (1) for land cover 
grid creation and (2) travel time calculation, the latter requiring the output of the first. 
Separating the two tools allows for simpler and faster execution to test multiple 
scenarios with the Travel Time Grid creation tool without having to recalculate the 
base land cover grid each analysis iteration. A flow chart of the processing steps and 
the connection between the two tool chains is provided at the end of this section. 
 

  For this section you can use the data: Travel time analysis - Example-Data (4.2mb) 

 
Screen videos of this application are available here: 
sagatutorials.wordpress.com/travel-time/ 
 
This work is described in more detail in an article (Fisher et al 2017) available here:  
https://ij-healthgeographics.biomedcentral.com/articles/10.1186/s12942-017-0086-8 
 
 
The data provided for this section includes a vegetation grid, elevation grid, road 
vectors, destination points and reclassification tables.  
 

Land Cover grid creation 
 
The Land Cover grid creation tool combines vegetation, transport infrastructure 
(roads) and elevation data to produce a raster grid of land cover including rivers and 
creeks.  The land cover grid is used as the basis for the travel time calculation with 
each land cover type being allocated a potential travel speed value. In the example 
shown here the vegetation and road data were pre-processed as follows: 
 

 Vegetation data was produced from Landsat 8 imagery and classified into 4 

broad classes; Forest, Scrub, Grassland, Bare Land. This data set was 

https://drive.google.com/file/d/0B2AvESxtL2YBZVc0Vnh0Z053SEU/view?usp=sharing
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produced at a 50-metre grid cell size and becomes the base grid system to 

which other created data are resampled to.   

 Road data was obtained as vector data and attributed into three classes 

based on infrastructure quality; class 1 national road, class 2 provincial road 

and class 3 local road. 

The elevation data is derived from SRTM data and used to create water channel 
data. The water channel data is created within the Land cover grid creation tool 
chain in the form of a Strahler order raster layer.  The Strahler order is a measure of 
flow accumulation within a landscape and within the travel time calculation is used to 
model barriers to travel based on different seasonal scenarios.  
 
Five Strahler classes are produced in the analysis grid with the highest class most 
likely to be impassable throughout the year. 
 
 
 
Use: Geoprocessing > Grid>Analysis>Travel Time Analysis>Land Cover 
scenario offset  
 
The Land Cover grid creation tool input window can be seen here to the left using 
the inputs: 

1. Timor_Barat_80

m (DEM) 

2. Veg (Vegetation) 

3. Roads, selecting 

class as the 

attribute  

4.  

 
 
 
 
 
 
  
The output grid, shown here, is 
randomly coloured. It helps to interpret 
the output if it is re-coloured using a 
more intuitive colour scheme. 
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To achieve this right click on the LC 
grid and select Create Lookup Table. 
Select “unique values” as the 
“classification Type”.  
 

 
 
Click apply in the Object Properties Tab then select Lookup Table as the colour 
Type 

 
 
 
 
 
Finally, Change the colours in the 
colour lookup table to produce an 
easily interpretable land cover grid 
image as shown here. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Travel Time Grid creation 
 
The Travel Time Grid creation tool travel time to destination in minutes and this 
data reclassifies as travel time or remoteness zones. The  Travel Time Grid creation 
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tool requires the input of the Land Cover grid, destinations points as vector data, and 
two reclassification tables.  

 The destination data is provided as vector points. These can be edited and 

moved or new point added after each run of the model to produce new output 

scenarios based on changing service provision.  

 The first reclassification table (see table 1) gives travel speed values for each 

land cover class calculated as the number of seconds to travel across one 

grid cell using the formula [Km/h x 180] where 180 is the number of seconds 

to travel  50 metres at 1 km/h. For the water-way classes (8-12) a very high 

(>99999) is given to allocate that class as a barrier (not crossable) due to 

flooding.  The travel time values can be altered after each run of the model to 

produce new output scenarios based on differing travel conditions 

 The second table defines a look up table (LUT) recolouring the output grid into 

travel zones. ( table 2). This is optional. 

Table 1. 

ID Cover Class km/h Travel Time (Sec) 

1 Forest 1 180 

2 Grass 2 90 

3 Bare, Rocky 3 60 

4 Scrub 0.75 240 

101 Stream Class 1 2 90 

102 Stream Class 2 2 90 

103 Stream Class 3 2 90 

104 Stream Class 4 2 90 

105 Stream Class 5 0 99999 

201 National Road/Hi-way 50 3 

202 Provincial Road 25 7 

203 Local Road/Track 10 18 

 
 
Table 2. 

 
 
 
 



141 
 

 
Travel Time grid creation tool 
input window can be seen here 
to the left using the inputs: 
 

1. Land Cover Grid derived 

from the Land Cover grid 

creation tool. 

2. Destpoints (Sestination 

points) 

3. LC_Speed (Table 1) 

4. TT_Zones (Table 2) 

 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
 

 
Output one is the travel time grid showing the distance to destination points in 
minutes. Output two is the travel time grid reclassified into zones using table 2. 
 

Interactive modelling 
 

Alternative travel time scenarios can be rapidly modelled three ways through: (1) 
altering the location and number of destination points, (2) changing the travel speed 
table and (3) editing the Land Cover grid. 
 
To edit the location and number of destination points 
select the point data layer on the data tab then use the 
pointer tool to select a point in the map window, right click 
and select Edit Selected Point . You can now move or 
delete the point. To add a point right, with the point data layer on the data tab 
selected, right click on the map window and select “Add Shape”  then select the 
location on the map where you want to add a new point and hit enter. 
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To change travel speed values right click on the travel speed table in the data tab to 
open the table then alter the values in the travel time column.  For example, you may 
wish to make all the travel time values for the waterway classes very high to model 
travel after a large rainfall event making all stream channels impassable or increase 
all the walking (non-road) travel times to simulate someone being carried. 
 
 It is also possible to directly edit the Land Cover grid, for example, to reduce travel 
speeds on sections of road known to be damaged or add new roads and tracks know 
to exists by planning participants but not otherwise captured in by the road data used 
in the initial analysis. To alter the Land Cover grid use the “Change Values 
Interactive: 
 
Use: Geoprocessing>Grid>Values>Change Values Interactive  
 
In the example shown to the right, the 
new value we wish to “draw” on the 
land cover grid has been set to 11 so 
we can draw a new local road.  If 
adding a barrier to travel, ie a new 
flooded area, set the radius to 1 or 
more to make a solid line. Note when 
drawing on the travel grid move the 
cursor slowly to paint a contiguous line. 
 
Now use the cursor tool to slowly draw then new cell 
values across the land cover grid. 
 
After editing the destination points, travel speed table 
and/or land cover grid it is possible to directly run the 
Travel Time Tool again to see new outputs. After each 
iteration of the model you can save the to output as a 
map graphic or a GIS file to further compare 
scenarios. 
 
 
 
 
 
Fisher, Rohan, and Jonatan Lassa. “Interactive, open source, travel time scenario 
modelling: tools to facilitate participation in health service access analysis.” 
International Journal of Health Geographics 16.1 (2017): 13. 
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11.2 Error matrix 
 
An error or confusion Matrix is a technique for comparing changes between two 
raster (grid) data sets. In order to produce a confusion matrix grid classes must be 
defined by the lookup table and values of the grid classes for each image year must 
be the same. We will use classified grids from 1996 and 2015 to create a confusion 
matrix. 
 
We also need an input look-up table to define the cell class names. Open the lookup 
table from the colour display input in the settings tab and save the table to 
Workspace as shown below. 

 
 
 
Give the Workspace grid a 
new the name in the example 
below the table has been given 
the name “LookUpTable”. 
Now we are ready to create the 
confusion matrix: 
 
Use: Geoprocessing > 
Imagery > Classification > 
Confusion Matrix (Two 
Grids) 
 
Classification 1 is the 1996 
grid, classification 2 is the 2015 
grid. The Look-up Table and 
the minimum, maximum and 
name values are given. 
 
 
 
 
 
 



145 
 

A new image will appear in the data tab. The image below is an example of what this 
image looks like with each colour representing a different change trajectory. For 
example in the image below the light blue colours indicate regions where closed 
forest has changed to grassland or other. 
 

 
 
It is also possible to view the histogram and table for this grid as we did for the cover 
classifications 
 

.  
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Opening the table shows you the change trajectory of each land cover type and the 
area of change. 
 

 
 
Note the values shown in this table are the count of pixels in that class value. To 
convert to metres square and kilometres square you need to: 

1. Multiply the value by 900 – this is the number m2 per 30*30 metre pixel. 
2. Divide by 1000000 (One million) to scale it to km2 

 
 
In the example above the area in km2 change from 
forest to grass in is 
222.7km2. (247509*900)/1000000 
It is possible at any stage to save a table to a .txt or 
.csv format for further analysis in excel. 
 
 
 
 

11.4 Atmospheric Correction 
 
Top of Atmosphere correction converts Landsat imagery reflectance by removing 
variation due to solar irradiance. 
 
Use: Geoprocessing>Imagery>Landsat>Top Of Atmosphere Reflectance 
 
Enter the bands you wish to correct tool the  will automatically create corrected 
bands 
Load the meta data txt file that comes with Landsat scene downloads (This contains 
TOA correction details).  Make sure you have the right Landsat sensor selected. 
 
 



147 
 

 

11.5 Troubleshooting 
 
This section should help with some common known issues with SAGA. Other 
question or queries should be directed to the SAGA development team through the 

source forge forum: https://sourceforge.net/p/saga-gis/discussion/ 
  

 
 
SAGA Crash! 
 
Due to the fact that SAGA runs 
via your computer's RAM 
allocation, large data sets can 
cause an overload crash.  There 
are three ways to deal with this: 
 

1) Working with a computer 
with a good RAM 
allocation. 

2) Clip larger data-sets to your area of interest. Avoid, for example, working on 
full Landsat Scenes if unnecessary.  

3) Save your data and associated project as you go to avoid losing your work. 
 
 

https://sourceforge.net/p/saga-gis/discussion/
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To save an individual grid just right 
click and choose save as. 
 
To save all produced data and the 
associated project structure use 
File>Save Project from the top of the 
menu.  

  
 
 

 
 

Opening unrecognised files 
 

Most files can be opened by dragging and dropping 
them into SAGA. If you try and open a file and it 
does not appear in the chosen window select “All 
Files”. 
  
 
 
 
 
 
 

Finding Geoprocessing tools 
 

If you can’t find the tool you are after or have an idea of the 
process you want to conduct and are not sure where it is 
within the SAGA menu structure use: 
 
 
Geoprocessing>Find and Run tool 

Enter a name or keyword related to 
the tool you wish to find then select 
the tool from the resulting list. 
  
  
 
 
 

 
 

Losing the Navigation toolbar 
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Usually, you have two tool bars under the top menu as shown below. 
 

 
 
Occasionally the navigation tool bar may not appear 
 

 
 
The easiest way to make it reappear is to simply drag the existing tool bar out of the  
toolbar area and drop it back in again. 
 

 
 

 
 

Finding more information about geoprocessing modules. 

 
All geoprocessing modules have an accompanying description of how they were 
derived and often with references to papers describing in detail the algorithms 
behind them. This can be found using the tools tab, selecting a tool and the 
description Tab. 
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